Dodge Cummins Diesel Forum banner

Edge Juice w/ attitude question.

1625 Views 30 Replies 5 Participants Last post by  jwalth02
i had my edge installed two days ago and the first day it ran spectacular!!! The second day i messed with the low end responsiveness, and my truck started acting really weird.. i would stomp on the gas and it acted like it was restricted..i didnt have much power... I contacted edge and they said try replacing the fuel filter which i did. NOW WHAT.. It still is acting up sometimes...?
1 - 20 of 31 Posts

· Registered
Joined
·
817 Posts
Have you pulled the codes yet? Do the key trick (on off on off on) and watch the odometer. Should come up with p PCU then p done then P Ecu then P done with any codes inbetween. Let us know what they are. :thumbsup:
 

· Registered
Joined
·
115 Posts
Discussion Starter · #3 ·
huh... im sorry can you explain this again... are you wanting me to look at the odo on my attitude? and am i just turning the power on not the truck...? and what am i looking for? sorry
 

· Registered
Joined
·
817 Posts
Sorry, put your key in the ignition, turn it to on (not start) then off then on then off then on and leave it. Your odometer on your dash will display:

P PCU
P xxxx
P Done

P Ecu
P xxxx
P Done

The x's are the codes, write them down and let us know what comes up.
 

· Registered
Joined
·
115 Posts
Discussion Starter · #5 ·
hey jwalth i just tried that and when i turn the ignition to power im looking at the digital odo and its just telling me the miles? what am i doing wrong?
 

· Registered
Joined
·
1,654 Posts
what level do you have the edge on? and what level do you have the low end responsivness on? Because when i turn mine on 5x5 the low end is super slow but just billows smoke. thats why i keep mine on 3x5
 

· Registered
Joined
·
817 Posts
It does that to me sometimes too either you're not doing it fast enough or it doesn't like you :hehe:.

Gotta cycle it quick and hold the key in to make sure it doesn't hang up on the lock.

Also do you have the fuel pressure gauge hooked up? What does it say you have for pressure?
 

· Registered
Joined
·
817 Posts
Hmmm. That 1693 means there's a code in the other computer. You're gonna need a scanner to pull it, if you can go to a checkers or autozone and borrow their scanner and find out what the code that's hiding is.

Other thing is like he said did you put the settings back to what they were before you started messing with it?
 

· Registered
Joined
·
817 Posts
Ya I do it there all the time. Just make sure to ask to use it not for them to come scan it. They're not allowed to clear the codes, if you ask they'll just ask for your ID for collateral and you can run it. Then you can clear the codes and see if they come back. But put them in here when you find what it is.
 

· Registered
Joined
·
1,654 Posts
P0341 Camshaft Position Sensor Performance / Rationality

P0237 Turbocharger Boost Pressure Sensor Low

did you put in the boost bolt they supplied with the edge?
 

· Registered
Joined
·
115 Posts
Discussion Starter · #17 ·
so what does this mean m5b6l. do i just need to replace these sensors? how expensive is that? is it a hard or easy fix?
 

· Registered
Joined
·
817 Posts
Either you've got a boost leak causing the low boost code or your map sensor is bad. The crankshaft sensor is probably bad too. The low boost is probably what's hitting you. Need to check your map sensor connections and probably pull it and clean it. Though first I'd start checking for air leaks. Did you say you hadn't lost any boost on the edge display?
 

· Registered
Joined
·
115 Posts
Discussion Starter · #20 ·
it doesn't feel like ive lost any boost pressure... where would i check to see if ive got boost leaks? also how much would it be to replace those sensors and is it a hard fix?
 
1 - 20 of 31 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top