Dodge Cummins Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I just got done searching, and couldn't find anyone with the same issues I'm having.

I've had a Jw/A on my '07 5.9 for a while now. When cruising along on level 1, it throws a P0148-fuel delivery code. Also at about 50% throttle, at any level, it surges really bad!!

I'm running a FASS 95gph pump, AFE intake and a straight pipe.

It's getting really annoying:banghead: Any ideas:confused013:
 

·
Registered
Joined
·
189 Posts
If it's an issue with the edge, its most likely in the harness. I'd try running the truck without the edge installed. If the problem persists I'd start looking at the cp3 and injectors. Particularly the metering valve in the fca
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
If it's an issue with the edge, its most likely in the harness. I'd try running the truck without the edge installed. If the problem persists I'd start looking at the cp3 and injectors. Particularly the metering valve in the fca
Should I unhook it completely, or just put it on 0?
 

·
Registered
Joined
·
1,708 Posts
Don't know about the fuel delivery code, but my Edge J/A Hot would surge on all levels. It's also a possibility that the Juice may need an update.
 

·
Registered
Joined
·
189 Posts
I'd unhook it completely. That will tell you whether its causing the problems or you have greater underlying issues
 

·
Registered
Joined
·
57 Posts
My buddy has same truck as yours and had a Edge w/attitude with the same surging problem and same code he called edge multiple times and sent it back in once to get reflashed and the problem persisted. They finally decided to switch out the entire unit harness and all and everything is fine now on all levels. So call edge and talk with them, his was out of warrenty so they charged him like 50 bucks I think.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
Sooo, I unplugged it and all the issues are gone. Guess I'll call Edge and see what to do, or just buy a Samrty:thumbsup:
 

·
Registered
Joined
·
189 Posts
Yep, I'm having somewhat similar issues with my Powermax. I guess when you run something that relies on that many wires and connectors there are just that many more places for something to go wrong... I'd ditch it and go with a Smarty for sure!
 
1 - 10 of 10 Posts
Top