Dodge Cummins Diesel Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
346 Posts
Discussion Starter #1
So people have been complaining to my dad about my smoke so he took the chip out. He unplugged it from the back of the box and when he did this the check engine light came on and the truck has no power at all anymore its worse than stock. My grandmas buick could beat that thing in a race. Theres somthing wrong and i dont know what it could be. In 6th gear and when i smash on the gas pedal it will go no where it slowly and i mean slow like turtle slow will it accelerate. Any ideas on what it is?
 

·
Premium Member
Joined
·
10,376 Posts
First that is the wrong way to disconnect your Comp. The data and MAP are still plugged in through the Comps wiring harness under the hood which is throwing your ECM curves. Tell dad to go out and reconnect the factory plugs back together.
 

·
Registered
Joined
·
346 Posts
Discussion Starter #3
Where are these factory plugs? We didnt put it in we bought it with it in it so i dont know where these plugs are.
 

·
Registered
Joined
·
346 Posts
Discussion Starter #4
Do i have to take all the wiring out or can i leave it in so when he decides to give me the chip back all i have to do is reconnect them
 

·
Registered
Joined
·
346 Posts
Discussion Starter #6
So i got one of the plugs off but the other one that dosent go into the motor i cant get. Ive tried every thing and i cant seem to get the dang thing out. The other one came off easily just pulled the red thing out and it came right off but the other one thats connected to the stock map plug that will go back in to where the edge map plug was cant seem to get off i pulled the red thing out but it wont budge at all im afraid to pull to hard cause it might break or somthing. It may seem like im weak or somthing but ive tried and i cant seem to get the dang thing out. Is there anything that would help to get it out. Its realy tickin me off cause the other one came out fine and my truck is worse than stock and i have to drive it to school everyday and i have no power at all. Any ideas? And do i have to dissconnect everything or can i just dissconnect the map and leave the rest hooked up? Will it hurt to leave the map plug out and just run it without it in or would it hurt somthing?
 

·
Registered
Joined
·
401 Posts
you need to get the edge unplugged from the map and reconnect the factory
 

·
Registered
Joined
·
346 Posts
Discussion Starter #8
Yea but i cant get one of the plugs undone
 

·
Registered
Joined
·
337 Posts
Um why don't you put the chip back in? Its your truck right? If you have to much smoke...Then stop getting on it!
 

·
Registered
Joined
·
689 Posts
the map sensor doesn't just pull out....you have to unclip it.
 

·
Registered
Joined
·
689 Posts
if your daddy paid for the box he can tell you wat to do with it...
 
1 - 12 of 12 Posts
Top