Dodge Cummins Diesel Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
Anyone who can help me on this... it will be greatly appreciated!!

I am prepping an engine harness for my 24V Cummins that is going into my 2004 Ford F350 (replacing the tired 6.0L diesel).

A problem I've run into is that the engine wiring harness seems to have swapped the oil pressure sensor (pin 06 on the ECM connector) with the PTO Sense Circuit (ECM Pin #26). I am not sure if this is an aftermarket mod, as I have two engine harnesses that have the same arrangement.

Here's the problem: All the ECM pinout diagrams I can find have Pin #6 as the oil pressure circuit with a grey wire with a black stripe.

Now, here's the question: I am assuming this is going to matter when I plug in my ECM and try to start the truck- but to what extent will it matter? I am not going to use the electronic oil pressure sensor as I am installing a mechanical gauge.

Has anyone any ideas why this harness would be different?
Should I go ahead and move the oil pressure circuit back to the #6 pin from its current #26 location?
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #2 ·
Also, if anyone has any idea how to tell if an ECM has a manual or automatic programming? I made the mistake of not marking my ECMs before I moved and they got mixed up.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top