Dodge Cummins Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My truck went into limp mode on the freeway i pulled the codes P0206, P2149. I looked up the codes so i know what they mean. Has anyone had this and what could possible be the fix for it i have called 2 stealerships with 2 different answers any help would be greatly appreciated.


My truck is a 06 mega cab with BullyDog Crazy Larry, AFE MeggaCannon 5'' turbo back exhaust, Valair DD clutch.
I dont beat my truck or race it i put the crazy larry on it for the gas mileage more than anything.

Thank You
Quinton
 

·
Registered
Joined
·
227 Posts
My truck went into limp mode on the freeway i pulled the codes P0206, P2149. I looked up the codes so i know what they mean. Has anyone had this and what could possible be the fix for it i have called 2 stealerships with 2 different answers any help would be greatly appreciated.


My truck is a 06 mega cab with BullyDog Crazy Larry, AFE MeggaCannon 5'' turbo back exhaust, Valair DD clutch.
I dont beat my truck or race it i put the crazy larry on it for the gas mileage more than anything.

Thank You
Quinton
Usually a P2149 means that the ECM has detected a circuit problem with injector 4,5, or 6. All three of these are driven by a common driver within the ECM. Usually a missfire will occur and the ECM will shut the affected injectors down. I would start by checking the connections under the valve cover. Check for broken wires or even just a little cut place in the wires, OHM them out all the way back to the ECM. Check your oil level and see what it is like. If your truck is under warranty i would get it to the dealer and let them have at it. If not I would get you check book ready because it could lead back to a faulty injector. Best of luck to you and I hope that it is still under warranty. :thumbsup:
 
  • Like
Reactions: bansheeair

·
Registered
Joined
·
13 Posts
Same thing just happened to me picking up the truck in Portland, got to Seattle and 20 minutes from the airport the check engine light came on and it went into limp mode.

What was your fix?
 

·
Registered
Joined
·
36 Posts
Mine did the same thing this morning. When I checked the codes all I had was a p0206. All the threads I can find mention the p2149. My truck doesn't go into limp mode either. It idles rough and shakes real bad under acceleration. I am thinking, haven't started pulling anything apart yet, that my problem will be the #6 injector since I don't have the other code. Any ideas on this one too?

I am heading out to start taking stuff apart.
 

·
Registered
Joined
·
13 Posts
I got mine back from the dealership yesterday, total came out to $2,875 had to replace all injectors and also replace the exhaust manifold.

My truck has 188,000 miles so it was about time to replace them. However if yours are just a little clogged I used a basic injector cleaner and was able to fix them enough to drive and additional 280 mile to get back home. Hope this helps and best of luck to you
 

·
Registered
Joined
·
36 Posts
Mine ended up being the #6 injector so while it was apart I sent all the injectors for testing. They were all on the low side for spray (all 6 were between 8 and 10 ppm, they should be between 5 and 7), so now I am getting all new ones. I have 150000km(93000 miles) on the truck so I would assume that the Edge EZ that was on the truck when I got it had something to do with it, it also had a generic type of fuel filter. Thanks to everyone on the forum I had removed the Edge and got a Smarty and started using Baldwin filters about a year ago or I might have had to do this sooner.
Since I am replacing all the injectors I am going to put in some DDP90's, next is a FASS system.
 
1 - 7 of 7 Posts
Top