Dodge Cummins Diesel Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi everyone, as the title states, im having a little vibration problem that id assume is in my drivetrain somewhere. My truck is a 2007 5.9l 2500 hd ccsb with 160k on the clock. When i bought the truck it had a humming noise from the front end which i was told by a shop it was the front hub assemblies having bad bearings. so i had them replaced about a month and a half ago. Turns out that wasnt the problem. The hum is still there, and sometimes there is a squeaking noise from the same area. And just recently, when between about 40 and 65-70 mph i will get a decent vibration under load. If i let off the throttle, the vibration seems to go away(atleast it decreasses) but then comes right back when i go to accelerate. I was wondering if the humming/squeaking may be related to the vibration under load through a bad joint or something in the drive shaft? Hoping anyone might have some thoughts for me on any of my problems, they would be greatly appreciated. Thanks in advance!
 

·
Registered
Joined
·
18 Posts
I have the same problem. I've been told it's a stiff u joint. I did change the oil in the rear end yesterday which was a little low and old. It did help out a lot. Now its so minor it don't bother me.
 

·
Registered
Joined
·
1,339 Posts
Sounds like a u-joint. If you have a long bed it could be the hanger bearing.
 

·
Registered
Joined
·
1,442 Posts
the vibration under load sounds a lot like a u-joint, the humming I'm not sure about.
 

·
Registered
Joined
·
39 Posts
Had similar vibration not too long ago. Had bad ujoint in driveshaft on axel side. Replaced both while drive shaft was out. $45, 5 beers and 2 hours later no more vibration. :party018:
 
1 - 5 of 5 Posts
Top