Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your truck HERE to be a part of December's Cummins of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 ·
I've got a 2012 6.7 with DPF delete, mini maxx and 5" TBE,Tonight after work I went for a drive into town, and I noticed something weird, when I was just cruising at about 110km/h I'd feel the truck slow, and I hadn't taken my foot off the throttle, and I looked and my boost had just dropped and then it would kick back to what it was at. Road was flat. Then I noticed I was set on cruise control at 110kmh, and I was holding 10psi, on a flat road. Also, when getting under load it's nothing for it to hit 20-27psi plus. Is there something wrong? I just run it on street, and never hard on it. In my setting it says "mild w/turbo" I think that's the aggressive tuning, is that what's going on here? Any help would be great.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
314 Posts
I don't run the aggressive turbo tune on mine, I could never keep it under 30 psi around town haha. It's normal for the vgt to run 10 pounds down the highway, however I haven't had it cut out like you mention. It does drop down to 0 psi goin down a hill or somthing but not on flat ground. Any chances you hit the cruise switches? How often does it do this?


Sent from AutoGuide.com App
 

·
Decoder Ring Specialist
Joined
·
2,615 Posts
Even without the ATT mine hits 30+ in a heartbeat. Stock intact tuning had them 26-28PSI at full song so 27 isn't anything outside of its normal. I don't like seeing mine over 32-34 and so don't let it get up there.
 

·
Registered
Joined
·
85 Posts
Discussion Starter · #5 ·
This morning I was on my way to work, and my coolant was at 120 degrees, and I was just tippy toeing down the road to work and I hit a small hill at about 5psi, and the boost just dropped, then kicked back in. Why is it doing that?!?!? 2012 6.7


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
314 Posts
Mine does the same since the MM install DPF delete and EGR still plugged in. On another thread someone suggested unplugging the EGR valve on top cooler but I haven't had a chance to try that yet.
 

·
Decoder Ring Specialist
Joined
·
2,615 Posts
It's probably still cycling/blending EGR in during warm-up. H&S definitely doesn't 100% have a handle on all the stuff that goes on during warm-up...not really their fault, have to remember, they don't exactly get any help from Cummins on this stuff.
 
1 - 7 of 7 Posts
Top