Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
242 Posts
Discussion Starter · #1 ·
ok, maybe not...

quick questions:

my fuel guage is only accturate to a half a tank then it is no longer accurate. where should i check first?

second problem is, my truck gets good and warm blowing from the heater just fine. but my temp. guage never gets very high? it gets up to the first line soemtimes, and sometimes just barely moves at all, never reads int he middle at all. what could be causing this and how do i fix it?

THANKSSSSSS!!!!:popcorn::popcorn::$:
 

·
Registered
Joined
·
1,145 Posts
check the wiring and the sending unit on your fuel gauge, i had the same problem in my 98.5
 

·
Registered
Joined
·
3,578 Posts
Yes, they do suck, but they're functional, so they don't suck that bad.
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #5 ·
its a 91.5 i think? right? its a 91 with an intercooler.
 

·
Registered
Joined
·
345 Posts
my truck gets good and warm blowing from the heater just fine. but my temp. guage never gets very high?
Check to see if you have a thermostat installed. It's an easy job and the seal is a rubber o-ring, not a gasket.

The engine runs better at normal operating temperature.
 

·
Registered
Joined
·
861 Posts
its prob your sending unit.....so common on the dodges
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #8 ·
even common for a bad temp. sending unit?
 
1 - 8 of 8 Posts
Top