Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
My truck has been acting up off and on. I will be driving along and my throttle goes dead. Truck continues to run usually at a high idle but is totally unresponsive to the throttle. If you continually pump the throttle sometimes it will start working and sometimes u can shut the truck off and restart it and it starts working. I have a fuel pressure guage so I know my lift pump is working. I talked to the guys at a local shop and they are convinced i am losing my injection pump. I am not convinced though because it runs fine 99% of the time and only occasionaly the throttle goes dead. It is throwing a code but I live way out in the sticks and by the time I get back to town the code goes off and it is not storing anything in my computer. I am thinking possibly Throttle Position Sensor, but looking to see if anybody else has had this problem and if they might have any other ideas. Thanks for the help. Oh one more thing when I lose throttle and it starts idling high sometimes the truck won't shut off either. Luckily my truck is a manual so I can put it in 6th gear and kill it. Any help would be appreciated. 02HO
 

·
Banned
Joined
·
2,613 Posts
well find out what the code is that would help allot just right it down or something then get on here and tell us.. I dont think its the pump though either..
 

·
Registered
Joined
·
204 Posts
To get the code, Cycle your key off-on three times ending with the key on and look in your odometer, it will display the code.
 

·
I DONT BELIEVE IT!
Joined
·
1,728 Posts
throttle position sensor . My buddys just went out on his 98.5 only 400 bucks at the dealer :$::CRY:
 

·
Registered
Joined
·
1,093 Posts
dead pedal?? Well I hope its just your tps. Mine was IP falure.:CRY: But use the key method when its acting up. Good luck.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #7
well thanks for the info. Now I guess I just have to wait for it to happen again and use the key cycle to display my code. Sometimes it goes for months without acting up, but now i know how to read the code so i'll get her figured out next time. Thanks again
 

·
Registered
Joined
·
788 Posts
My TPS went out and threw a code aswell. I was just a sitting duck until it decided to let me move again. Scared the piss outta me the first time it happened. I cycled the key on alot of times to clear the code and it worked again until it went out on me again. I had to end up getting a new one. And its not cheap. Have you looked at putting a second pump on the Frame of your truck? or some sort of fuel system? I installed a pusher pump on mine and It keeps plenty of fuel going. Just curious, The VP inst fun to replace either.
 
1 - 8 of 8 Posts
Top