Dodge Cummins Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I'm not an avid poster but I believe I may have helpful information for others. If this has already been addressed, my apologies.

I have a 2014 CCSB 2500 (68) and I have experienced the "dead pedal" issue since I purchased the truck 8 months ago. So, I have now put over 10,000 miles on the truck and had it at two different dealerships a total of five times for my dead pedal complaint among others. One dealership basically laughed me out and claimed "without a CEL, we can't do anything." The second dealership would listen to the problem but, they were unable to duplicate.

The "dead pedal" is a huge deal and has almost killed me more than once. I have had more middle fingers and honking horns than my 90 year old grandma due to this problem. I have seriously contemplated selling the truck and trying a different brand because of this one problem. I have owned four diesel Rams throughout the years and I love the Cummins. I'm not brand bashing, just trying to convey the severity of the situation.

Onto the fix (maybe?). I was sitting in the truck, waiting on the wife, truck running in park, after almost getting T-boned (due to the dead pedal), fuming pissed off, and I started playing with the buttons on the steering wheel clicking through the EVIC. I don't like ABS, I don't like traction control, I don't need a car that parallel parks itself, etc... I HATE all of that bs. I noticed Hill Start Assist was "checked" on the EVIC under Settings. Did I mention I hate computers trying to do the driving for me? I UNCHECKED (de-selected) that function.

That was about 500 miles ago. Haven't had the "dead pedal" once! Hopefully this is not a fluke. I would have had the issue at least five times by now. Now, nada.

Thought it was worth posting. Hope this helps others and hopefully I don't look like a dip$hit if it occurs tomorrow.
 

·
Registered
Joined
·
278 Posts
Wow!...440+ views, and no responses. :confused:


Anything that will improve the throttle response and power delivery of my turd is always welcome.

Thanks for the thread. I'm gonna' try this. :beer


.
 
  • Like
Reactions: normjet

·
Premium Member
Joined
·
2,550 Posts
Interesting. I may try it. Thanks!
 

·
Registered
Joined
·
1,213 Posts
Hill assist has been unchecked for thousands of miles,but I still have dead pedal.
Glad it worked for you.
 

·
Registered
Joined
·
5,244 Posts
Have them do some updates that removed my dead pedal, I have a thread about it try searching (PCM update and no more dead pedal) or go to my profile and look for threads started by me.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
JAH - thanks man. That was the intent of the thread. It is just info that has helped me.

Probleminfected - I think the goal is to have the truck perform the way it should without spending additional money on aftermarket parts.

2500/6 - Hopefully, your luck doesn't rub off on me. I'm still dead pedal-less.

ChrisJ208 - I had the dealership perform PCM flash 18-19-04-BD and DCU flash 18-19-18-92. That information is straight off of my service invoice. The dealership claimed there were no additional flashes to try. I'll give your thread a look. Your thread may be the reason why I brought the truck to the dealer in the first place?
 

·
Registered
Joined
·
5,244 Posts
JAH - thanks man. That was the intent of the thread. It is just info that has helped me.

Probleminfected - I think the goal is to have the truck perform the way it should without spending additional money on aftermarket parts.

2500/6 - Hopefully, your luck doesn't rub off on me. I'm still dead pedal-less.

ChrisJ208 - I had the dealership perform PCM flash 18-19-04-BD and DCU flash 18-19-18-92. That information is straight off of my service invoice. The dealership claimed there were no additional flashes to try. I'll give your thread a look. Your thread may be the reason why I brought the truck to the dealer in the first place?
I know after my updates it was gone, the number may be different now I had a another flash done a few days ago, I will have to check and be sure it's still gone.
 

·
Registered
Joined
·
6 Posts
Norm, thanks for the thread. I tried this two days ago and while it didn't solve the problem completely, it did help a little.
 
1 - 10 of 10 Posts
Top