Dodge Cummins Diesel Forum banner
1 - 15 of 15 Posts

· Registered
Joined
·
99 Posts
Discussion Starter · #1 ·
Does the cruise control carry a in line fuse that would be under the hood or in the fuse block? :confused013:Mine is not working and its a 2002... Not a big issue but if its a fuse this is a easy fix.
Mike b
 

· Registered
Joined
·
433 Posts
Not to steal your thread but i have been wondering this too. My light wont come on at all but we just rebuilt the vacuum pump.
 

· Registered
Joined
·
40 Posts
I also have a similiar problem except for my light comes on but when i hit the set button nothing happens.
 

· Registered
Joined
·
800 Posts
trace your vaccum lines down, most of these lines dry rot and crack causing leaks. There is a main line coming off the top of the vaccum pump thats bad for this also
 

· Registered
Joined
·
99 Posts
Discussion Starter · #9 · (Edited)
Well no light comes on. It maybe a vacunm line, I was horsing around under the dash replacing the dang e brake handle and could have bumped something. Let me check there first. I am sure to keep you posted in progress.
Mike b
 

· Registered
Joined
·
918 Posts
If the light does not come on then I would assume an electrical problem like a bad switch or fuse. If you have a vacuum leak, the light should still come on, you just won't have any cruise function and also no heater blend door control if the leak is bad enough.
 

· Registered
Joined
·
343 Posts
my truck is the same way cruise stopped for no reason... no light and no cruise, although my heater thing that selects where the air comes out still works. I was assuming electrical issues but where do you start?
 

· Registered
Joined
·
711 Posts
From what i understand, and from what I personally have experienced is that if you have the cruise light illuminated, but with no cruise, than you have a vacuum problem, but if you have no light than it will be electrical.
 

· Registered
Joined
·
99 Posts
Discussion Starter · #13 ·
Well that seems to be right. In the summer i will have the air on then hot a bump and I get hot air. Does these two go together like peanut butter and jelly? Could the issues be related? I had looked at Vacuum lines and they seem to be OK.
Mike b
 

· Registered
Joined
·
90 Posts
cruise question

i dont have cruise on my 99 cummins ,does anyone know what the easiest way to go about getting it is?,ive thought about buying all the used parts from other trucks but that could get spendy or buying some sort of kit but i dont even know if they make that for these,anyone know ?thanks
 

· Registered
Joined
·
286 Posts
Well that seems to be right. In the summer i will have the air on then hot a bump and I get hot air. Does these two go together like peanut butter and jelly? Could the issues be related? I had looked at Vacuum lines and they seem to be OK.
Mike b
Mine does the same thing with the same problems.... :banghead:
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top