Dodge Cummins Diesel Forum banner

Cruise Control auto to manual swap

18230 Views 12 Replies 6 Participants Last post by  kmc77
This may be old news by now i havent been on for awhile. I did a auto to manual swap in october of last year. I made it all loook like it came from factory with the manual, the only problem was i could not get my cruise control to work. :doh: I spent along time looking on here and all over the internet for a sure fix to this problem.:banghead: I finally found the fix if any body is interested let me know......
1 - 13 of 13 Posts

· Registered
Joined
·
52 Posts
Discussion Starter · #4 ·
there are two circuts that you are dealing with. The first is the the clutch switch. When you go to install the your clutch master cylinder you pull a jumper wire that has power running threw it and install you your clutch swicth that makes this circuit complete only power when the clutch is depressed. What this wire is, is the power wire that comes from the ingition switch, for the starter motor. Okay now the first part of the circuit is completed the starter has power... Now it needs grounded so on a auto when the trans is in park or neutral the park nuetral saftey switch gives the ground to complete the circuit. So all of us who who have done this swap installed our clutch switch and grounded the wire Blk/white to a good ground, HORRAY our truck starts. Now our cruise control doesnt work. The reason it doesnt work is the cruise circuit to work is looking for a speed (above 36 mph) and a open ground circut showing the trans ISNT in park or neurtal. But we need this for the starter. Here is the solution on your PCM on connecter 1 circuit 4 is the wire that showes this being in park or drive so it will work. To find this wire you will have 3 connecters on your PCM Blk , White , and gray. Find your black connecter , then find a black with white tracer( only blk with white tracer in this connecter. CUT IT NOW GO DRIVE YOUR TRUCK AND USE YOUR CRUISE CONTROL!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 
  • Like
Reactions: BanjoGabe

· Registered
Joined
·
52 Posts
Discussion Starter · #5 ·
Also if yoiu dont find this wire maybe it isnt the same color on all truck years just let me know and give me time a and i will try to figure your wiring out I will need to know what year and model and if you converted it from gas to diesel at some point
 

· Registered
Joined
·
693 Posts
Ill have to go try this then I can ditch the relay set up I have to make mine work.
 

· Registered
Joined
·
1 Posts
just did this on 01 threw 2 codes p0720 low output speed sensor & p1899 pnp switch failure , this caused total power loss at 1600 rpm cleared codes & reconnected wire now revvs to 3800 no prob. . any thoughts??
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top