Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Cummins of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I recently purchased a '94 12V with about 200k miles- it ran great up until last week. I went to start it and it had a rough idle, drove it down the street and it was puking white smoke, popping and had no power. Got it back and realized a copper line (that i think goes to the fuel pressure gauge) had snapped and was dumping fuel. I plugged it, put new filters on (has fass system). Now i have fuel up to my injection pump but not going to past that. Has anyone else had an issue with this that can shed a little light before I throw a $1,200 part at it? Relay is good and the solenoid seems to be functional.
 

·
Registered
Joined
·
18,806 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Ended up being a missing shim on the injection pump, when I went loosened the line it gave the line enough space to get fuel moving again. New shims fixed her up. Thanks for the help.
 

·
Premium Member
Joined
·
1,538 Posts
Ended up being a missing shim on the injection pump, when I went loosened the line it gave the line enough space to get fuel moving again. New shims fixed her up. Thanks for the help.
Can you explain this further? Missing shim where??
.
.
.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I circled the shim in red. I guess when I was having the issue with the busted line/popping/white smoke, this popped up and the shim fell out. I noticed it wasn't seated so I tightened it down and it must have cut the fuel flow. Retraced my steps and loosened the nuts a bit and it started right up.
911727
 
1 - 5 of 5 Posts
Top