Dodge Cummins Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
Well could they?
 

·
MI Chapter President
Joined
·
5,687 Posts
I dont think it would, but a dirty filter will.

youre talking about a pre-filter like a AFE correct?
 

·
Registered
Joined
·
108 Posts
Discussion Starter #3
yes a prefilter on a k&n cold air intake the prefilter was oily and dirty. Hauling a trailer the other day egt's got to 1600. The temp sensor is after the turbo on the exhaust brake
 

·
Registered
Joined
·
2,340 Posts
yes a prefilter on a k&n cold air intake the prefilter was oily and dirty. Hauling a trailer the other day egt's got to 1600. The temp sensor is after the turbo on the exhaust brake
:thud:1600* after the turbo!
That puts you at about 1900* pre-turbo. That's way hot. Piston melting hot. I'd be careful to not get it there again.
Randy
 

·
Registered
Joined
·
108 Posts
Discussion Starter #5
how could a guy tell there was any piston damage?
 

·
Registered
Joined
·
1,573 Posts
yes a prefilter on a k&n cold air intake the prefilter was oily and dirty. Hauling a trailer the other day egt's got to 1600. The temp sensor is after the turbo on the exhaust brake
:eek::eek::eek::eek: :thud: That is really hot! How long did you run it at that temp?? :w:
 

·
Registered
Joined
·
108 Posts
Discussion Starter #7
my wife was pulling the trailer so not sure.I havent driven it since but to back the trailer around. In am going to get a load of hay this afternoon. Is there anything I should look for while driving. Also what could cause these temps? chip was on stock and the truck has never had a problem pulling. Even with 2 more horses on board. the only thing I could think of is the filthy pre filter. The truck isnt putting any codes off to the bully dog so do you thing I dodged a bullet. Lots of questions on my end sorry
 

·
Registered
Joined
·
2,340 Posts
If you haven't already, take the pre-filter off and check the EGT's.
Do you have a boost gauge,and is it running normal?
Do you have alot of smoke?

Could be a bad reading on the EGT gauge--just a thought.

Randy
 

·
Registered
Joined
·
108 Posts
Discussion Starter #9
just drove it ran fine thankfully.put about 2800 lbs of hay on it and it pulled through mountains fine. Not smoking.
 

·
Registered
Joined
·
1,960 Posts
tough truck i would not be that lucky
 
1 - 10 of 10 Posts
Top