Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 ·
i noticed my comp was wasnt on today so i tried turning it on and it would do anything...so i unplugged it from the back and plugged it back in and still nothing...checked the fuse...everything was fine...checked the ground...good too...i wondering if i coulda shorted something out but wouldnt it have blown the fuse if i did?? and another thing im wondering is if i bought it used would edge still warranty it if i sent it in??? any help would be appreciated...:thumbsup:thumbsup
 

·
Registered
Joined
·
344 Posts
try dropping this one in the 2nd gen forums.

But my take is the comp might be fried.....do you notice any power gains even though the lights are not on? May just be the LED is not working?
 

·
Registered
Joined
·
12 Posts
Well edge always has stuff wrong with their products. The best thing to do is take it off and stick it under your tire and run over it because by buddy has the edge juice with attitude and he has the same problems. Some days it will come on and others it wont come on at all and edge says there is nothing wrong with it. So i would just throw it away.
 

·
Premium Member
Joined
·
10,376 Posts
Edge has great customer service and makes a excellent product.

I have been running my Comp for the past four years and no problems. I would give Edge's technical support team a call and tell them your problem.
 

·
Registered
Joined
·
247 Posts
My comp box did the same thing, sometimes would come on, sometimes wouldn't, if it didn't I just turned the key off and back on again and it would work, I checked all the wiring and fuses could find no problems, ended up calling edge and they gave me a new box. Seems good so far. a few months now.
 
1 - 5 of 5 Posts
Top