Dodge Cummins Diesel Forum banner

cold start ruff choking sputter at idle

4941 12
I have been noticing lately when starting my truck in the morning when its cold. temps from 9 to 25 degrees. heat grid cycles once the she fires right up fine.after a few seconds it stumbles chokes and runs ruff for a few seconds and then clears up.A rich blueish smoke is evident from the pipe and stays that way until at operating temp. could this be injectors?I have fresh rv 75's in it with a fresh engine with maybe 12K on it now.
1 - 13 of 13 Posts

·
Mopar1973Man.Com
Joined
·
26,034 Posts
Might want to double check the grid heaters for function.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #3 ·
they seam to be working as the wait to start light functions and relay clicks when the light goes off then I start it
 

·
Mopar1973Man.Com
Joined
·
26,034 Posts
they seam to be working as the wait to start light functions and relay clicks when the light goes off then I start it
Means absolutely nothing if the fusible links have rotted off the batter positive post or the fusible links have burned in two in the skin. Maybe the solenoid connects have burned where the still click but do nothing.

Check for 12V at the grid heater at first key on cold engine both terminals should be hot. After starting only one terminal will be hot.

The reason I know this because I normal unhook my grid heater power lead from the driver side battery in the spring (April) and hook it back up in fall (October). Wait to start and everything still functions but the grid heater are completely dead with zero error codes.
 

·
Registered
Joined
·
4,832 Posts
If it was a bad grid heater relay or something similar I would have expected it to start slow and run rough from the start not a few seconds after firing up. Nearly reminds me of a bit of air in the system or a possible sticky injector?. Are the interior lights dimming when the wts is on?. They should be from the draw on the batteries.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #6 ·
Thanks guys,i will check the voltage,i have not noticed a dimming which could very well be my issue as per mopar mans statement,this is a fresh engine and I need to drive the truck will I cause any further issues if I cant get to the fix till next week?
 

·
Mopar1973Man.Com
Joined
·
26,034 Posts
Thanks guys,i will check the voltage,i have not noticed a dimming which could very well be my issue as per mopar mans statement,this is a fresh engine and I need to drive the truck will I cause any further issues if I cant get to the fix till next week?
Hard starting. I don't think it will be all that bad. But try to fix it soon.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #8 ·
I wish I could leave my truck with Mopar Man for a few weeks and get things ironed out.LoL
 

·
Mopar1973Man.Com
Joined
·
26,034 Posts
I wish I could leave my truck with Mopar Man for a few weeks and get things ironed out.LoL
Drive it to Idaho I'll do it. :party018:
 

·
Mopar1973Man.Com
Joined
·
26,034 Posts
I would have a nice long list lol sounds tempting
Just remember I'm in the middle of nowhere Idaho so make sure to bring everything with you. My local part store is 52 miles away. Seriously doubt anyone would come out to my place I so far out here in the woods...
 

·
Registered
Joined
·
398 Posts
Just remember I'm in the middle of nowhere Idaho so make sure to bring everything with you. My local part store is 52 miles away. Seriously doubt anyone would come out to my place I so far out here in the woods...
Sounds like someone's got it made. I'd take that anyday. Lol

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #13 ·
Ok here is an update,the truck decided on its own to start cycling the heat grid,I have no dimming or voltage drop on my gauge when the truck was acting up in the previous post.Now she is acting just fine cycling the heat grid and nomore rich smoke or sputtering she is fine,It must have been a gremlin
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top