Dodge Cummins Diesel Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
309 Posts
Discussion Starter #1
I usually let the truck warm up for a few minutes (10) before I drive it away, I say usually but there have been occasions where I'm late to work and don't let it warm up but am real gentle til I see the temp gauge move up off the 140° mark. Recently on a trip I started and drove it so as not to irritate the other people in the campground, well I noticed it has no power until it gets over say 120° (Before the temp gauge moved). once it warmed up it ran great all day on the way home from camping. Now I don't let it warm up on purpose to see if the Edge gauges will tell me anything, I checked codes and am getting a 0216 (Fuel timing), and 0237 (MAP sensor voltage too low). I assumed this is from the edge. No check engine light.

What I'm gettin is it revs slowly and falls flat, (aboiut 1500 RPM Max.) Fuel pressure not below 12, boost not above 5, EGT around 550°. it will downshift trying to gain more rpm with no luck. Isit a few minutes to let it warm up a bit and it runs completely normal. I'm thinkin its a temp related issue, I've changed the coolant temp sensor and the IAT sensor, I also put a 180° t-stat in it while I was at it. still have the problem.

Any suggestions?

Thanks
 

·
Premium Member
Joined
·
5,382 Posts
The 0216 is the death code for the VP44. You might clear that code and see if it comes back.

Are you getting any smoke when it falls flat?
 

·
Registered
Joined
·
309 Posts
Discussion Starter #3
No smoke that I noticed. prior to the first time this happened it ran really rough and smoked really bad.

So I should have no codes even with the Edge?

How do you clear the codes? I disco'd the batts and had none til I started it up thay all came right back.

Thanks
 

·
Registered
Joined
·
33 Posts
Those symptoms are identical to mine last year when I had to replace my VP44. After replacing the VP44 and also installing a FASS, is running like a champ. Sounds like a good place to start.
 

·
Registered
Joined
·
309 Posts
Discussion Starter #5
OK so this morning was the coldest morning all week and it ran great...... still have the codes though. :(
 

·
Mopar1973Man.Com
Joined
·
26,292 Posts
The 0216 is the death code for the VP44. You might clear that code and see if it comes back.
:agree2:
Yea.. The P0216 is the death code for the VP44. The Edge is not the cause of it. But low fuel pressure is...

Here is the OBD II Error code page...
OBD II Error Codes

Here is the fuel pump diagnostics...
Lift Pump Diagnostics

Here is how to replace the VP44
VP44 Replacment

And here is how to reprime the fuel system...
Reprime Fuel System

That should cover you...:w:
 

·
Registered
Joined
·
309 Posts
Discussion Starter #7

·
Mopar1973Man.Com
Joined
·
26,292 Posts

·
Registered
Joined
·
309 Posts
Discussion Starter #9
So I swapped out the IP in 3 hours got it running good then changed the LP. did that and now i runs much better the EGT's are lower but boost is still low.
 

·
Mopar1973Man.Com
Joined
·
26,292 Posts
Wastegate sticking open a bit??? Boost elbow installed??? Boot leaks??? Crack Exhaust Manifold??? Plugged Air Filter??? Plugged CAT/Muffler??
 

·
Registered
Joined
·
309 Posts
Discussion Starter #11
Wastegate sticking open a bit???Not sure, I can move it with pliers Boost elbow installed???Nope, Auto truck Boot leaks???Doubtful Crack Exhaust Manifold???Nope Plugged Air Filter??? Plugged CAT/Muffler??Non Catalyst, good flow
Not gettin black smoke either???? :thud:
 

·
Registered
Joined
·
112 Posts
What do your fuel filter(s) look like?
It takes next to nothing to start having problems with a VP44 if for "ANY" reason the under engineered "stock" fuel system isn't up-graded to compensate for Chrysler's ($) agenda. If you do not have some sort of a pre-filter on your lift pump (which is junk), you should come up with something. I'm a big fan of #1221 Perma-Cool filter set-up, it's cheap and takes care of a major lack of a no pre-filter from Dodge INC.

Flame ON,
p.c
 

·
Registered
Joined
·
309 Posts
Discussion Starter #13
I borrowed a friends code scanner and read the codes and sure enough, 0237 and 0216, cleared them out and no more codes and they dodn't come back this morning after my ride to work. :hyper:

I think the 0237 MAP Low E code came from when I installed the Edge and I ran the engine to clear out the chips from teh EGT drill and tap and the MAP wasn't hooked up??????

Hopefully good to go now.
 

·
Mopar1973Man.Com
Joined
·
26,292 Posts
P0216 is the death code of the VP44...:thud:

You could try put 2 cycle oil in the fuel to extend its life but I doubt at this point it will do much good...
 

·
Registered
Joined
·
309 Posts
Discussion Starter #15
P0216 is the death code of the VP44...:thud:

You could try put 2 cycle oil in the fuel to extend its life but I doubt at this point it will do much good...
Hey, I just swapped out the VP saturday, just clearin the old codes out. their not back. :woot:
 

·
Mopar1973Man.Com
Joined
·
26,292 Posts
1 - 17 of 17 Posts
Top