Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Banned
Joined
·
1,844 Posts
Discussion Starter #1
i just put in a new volent cia with the new powercore filtre enclosed kit,looks sharp but am trying to figure out why its making my engine light come on and making my catylyst % warning go from 70 to 80 to 100% then back down to 70% then full then back down ect ect ect then after i drive for awhile the truck beeps at me 3 times then the catylyst stops doing that but the engine light stays on and then i'll be driving at a 100kmh again and then do that all over again this is freaking me out just wondering if the 2007.5 6.7L is not supposed to have one or what or is there some speacial sencors or other gear i have to add to make it normal ppplleease help:CRY:
 

·
Banned
Joined
·
1,844 Posts
Discussion Starter #2
well just founf out from volent that because i dont have a factory exhaust from the cat back that it will throw off the sencors go figure,they didnt tell me that when i bought it,a$$holes so its comin off and gettin refunded in full,so for those guys who run with a cat back exhaust you cant run a cia as far as know
 

·
Registered
Joined
·
297 Posts
Would have been nice to know huh?
 

·
Registered
Joined
·
586 Posts
are you serious I just ordered both things for my 6.7 and they never told me anything about that :CRY:
 

·
Banned
Joined
·
1,844 Posts
Discussion Starter #5
ya it wouldve been nice to no before i spent $650 buckeroos?it was a nice unit and it was working fine untill the pf started acting up,just like my roughnecks,volent was whining about the refund so i set them straght the bastards,the 6.7 is so pickey i wish they had the 5.9 in stock before i bought this one,its a nice truck but you cant realy do anything with it its realy starting to get annoying,but i do have a new pillar and gauges coming so i knock on would that those dont give me a problem,i ordered the pyrometer and tranny and boost gauges with the a-pillar to match the truck those are real nice too,they call them phantom white what ever that means but looking forward to it?????
 

·
Banned
Joined
·
1,844 Posts
Discussion Starter #6
are you serious I just ordered both things for my 6.7 and they never told me anything about that :CRY:
better make up your mind what you would like better ? a bigger whistle or a beefer exhaust i like my mbrp its nice
 

·
Banned
Joined
·
1,844 Posts
Discussion Starter #7
well my budd figured out why the cai wont work there was blowby on the sensors so he took them off and filed the ports flush and then put them in and it works good now,wow who would know but now my warning indacator is on saying that i need to service my air filtre evan though theres a new powercore filtre in there do i have to have my dealer flash it or is there a way i can reset it
 

·
Registered
Joined
·
503 Posts
In the know dealers are telling everyone with 6.7s not to install CAIs, even when running stock exhaust. Drop-in filters using the stock air box seem to be the way to go. There's also some indications that the large insulator section of the tube should be left in place, as it won't affect air flow and helps keep the column of air cool. I know guys who have had good results by adding a drop-in and a cold air duct from the stock box to the slot in the front bumper. I'm playing the wait and see game.
My truck is an '07, just coming up to 10,000 KMs. It's getting 20ish calculated MPG on the highway in 2wd. No codes! All stock.
 

·
Banned
Joined
·
1,844 Posts
Discussion Starter #9
In the know dealers are telling everyone with 6.7s not to install CAIs, even when running stock exhaust. Drop-in filters using the stock air box seem to be the way to go. There's also some indications that the large insulator section of the tube should be left in place, as it won't affect air flow and helps keep the column of air cool. I know guys who have had good results by adding a drop-in and a cold air duct from the stock box to the slot in the front bumper. I'm playing the wait and see game.
My truck is an '07, just coming up to 10,000 KMs. It's getting 20ish calculated MPG on the highway in 2wd. No codes! All stock.
thats funny my dealer tells me its fine to run my cai with my 6.7 that it wont hurt my engine at all i have the volant w/the powercore oilless filtre its supposed to be the best filtre out there so eitherway if my dealer says its fine then cool if they say go back to stock then i will
 

·
Registered
Joined
·
37 Posts
My AFE will show service air filter if i run the prefilter on it and push the truck hard, my theory is it has to much restriction and the computer reads this.
 
1 - 10 of 10 Posts
Top