Dodge Cummins Diesel Forum banner

1 - 20 of 53 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
So I was driving did a wot to figure out tuning and my check engine light came on I stopped to park it and flipped the key three times and got the p1693 code on my boost gauge came close to 50psi as I’m running a super b single turbo I pulled up diagnostic codes on my quadzilla and got nothing could this be an over boost code but not showing it ?
 

·
Registered
Joined
·
7,723 Posts
P1693 DTC Detected in PCM/ECM or DTC Detected in ECM
A Companion DTC was set in both the ECM and PCM.

There is a code stored and the PCM & ECM both know about it.
It may be from an old code or you'll need a scan tool to see it.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #3
P1693 DTC Detected in PCM/ECM or DTC Detected in ECM
A Companion DTC was set in both the ECM and PCM.

There is a code stored and the PCM & ECM both know about it.
It may be from an old code or you'll need a scan tool to see it.
The code cleared itself after about 5 starts then came back after driving it for about 30 min when the light comes on power stops for about 2 seconds then comes back on perfectly. I only lose power for two seconds when the light goes off then comes back on. I’m assuming it can’t be a bad code if the truck runs perfectly with the light on and off just curious why it comes on and off
 

·
Registered
Joined
·
74 Posts
Discussion Starter #5
go scan codes with a code scanner. The quadzilla doesn't read codes on a 2nd gen.


Guessing it is a map code.
What scan tool should I buy or who should I go to I want the dealership to be the last resort
 

·
Registered
Joined
·
74 Posts
Discussion Starter #8
just go to a autozone or similar and borrow one.
Guy at autozone said it was the throttle position sensor does that make sense? It seems like the throttle is fine no jumping Surging and the code cleared itself and came back on after driving it
 

·
Registered
Joined
·
74 Posts
Discussion Starter #10
What was the xode number?
I asked the guy for the code number and he said that scan tool didn’t give him one just read the code as throttle position sensor which puzzled me too
 

·
Registered
Joined
·
13,257 Posts
There are 3 different apps codes.

If you wanted to buy a scanner i would recommend a obdlink.

Onceyou know the code go to mopar1973man and look it up. There is troubleshooting for all codes
 

·
Registered
Joined
·
74 Posts
Discussion Starter #12
There are 3 different apps codes.

If you wanted to buy a scanner i would recommend a obdlink.

Onceyou know the code go to mopar1973man and look it up. There is troubleshooting for all codes
I was looking at obdlink is there any difference for dodged when it comes to like lx or mx, mx+
 

·
Registered
Joined
·
7,723 Posts
I'd try another parts store for a scan.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #15
Not that i know of. I have a mx
For some reason the check engine light cleared itself and hasn’t came on for about 100 miles and everything seems to be running just like it did before the light came on I’ll keep y’all posted if hits the fan
 

·
Registered
Joined
·
19,171 Posts
Maybe you got an over boost from WOT and a quick let off. It has reset and all is well in the world. Autozone guy knows not how to run toool. All tools give code AND description. High or low voltage codes for an apps are common when nothing is wrong commonly except maybe a loose wire or dirty battery terminal or if you have had something disconnected working on it. It is not a code to sweat if nothing is wrong.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #17
Maybe you got an over boost from WOT and a quick let off. It has reset and all is well in the world. Autozone guy knows not how to run toool. All tools give code AND description. High or low voltage codes for an apps are common when nothing is wrong commonly except maybe a loose wire or dirty battery terminal or if you have had something disconnected working on it. It is not a code to sweat if nothing is wrong.
The code came back on did the same thing when the light flashed I lost the pedal when it stopped flashing everything was good just seemed like it was low on power and idling weird I have a fuel pressure gauge and it’s never gone under 10 I have a fass 165 I have receipts for new injectors and vp44 that are less then a year old so I don’t think it’s those either I’m starting to wonder if it is the throttle position sensor or apps
 

·
Registered
Joined
·
19,171 Posts
I think you have dirty battery terminals or a bad alternator. Check alt for output over13.5 or 14. AC should be under ,05v ac.
APPS can be checked/monitored by tapping pin/wire #3 in its plug and running wires to cab and monitoring it with a volt meter for about .5v at idle and graduate smoothly with out skipping to about 3.7v at WOT. What apps is on it Factory, Timbo or other?
 

·
Registered
Joined
·
74 Posts
Discussion Starter #19
I think you have dirty battery terminals or a bad alternator. Check alt for output over13.5 or 14. AC should be under ,05v ac.
APPS can be checked/monitored by tapping pin/wire #3 in its plug and running wires to cab and monitoring it with a volt meter for about .5v at idle and graduate smoothly with out skipping to about 3.7v at WOT. What apps is on it Factory, Timbo or other?
I’m pretty sure it’s the factory one, so I should just hook up a volt meter the the alternator ?
 

·
Registered
Joined
·
19,171 Posts
Yes to check DC charging voltage when running or for AC voltage when running . For ac you need to use a good VM with a 2 volt scale not 20 or 200 v scale.For terminals use a scraper or wire bush cleaner and get good metal to metal connections on all ends and check cable for corrosion or resistance/voltage drop between batteries and connections.
 
1 - 20 of 53 Posts
Top