Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 14 of 14 Posts

·
Premium Member
Joined
·
809 Posts
Discussion Starter · #1 ·
EGR POS SENS VOLTS TO HI.
Service dept. says that my afe stage II mega cannon or any open air intake will cause that code. They won't check for problem with egr unless I put factory box back on and bring back. What is yalls opinion. I calll bs. Said unhooking battery cables won't clear all codes. I asked him if they cleared them with starscan he siad yes so I'll see but I bet not.
 

·
Registered
Joined
·
203 Posts
that would seem to be incorrect... I think they are blowin smoke
 

·
Registered
Joined
·
319 Posts
IMO B.S. I have an open air intake and not one problem!
 

·
Registered
Joined
·
265 Posts
that code would not get set from your air intake. it probly needs the egr cleaned out and maybe a sensor also.
 

·
Registered
Joined
·
281 Posts
What the hell does more air have to do with EGR? Sounds like BS to me. It is only an air filter.
 

·
Registered
Joined
·
13,651 Posts
I have had an AFE Stage II with PG7 on my truck since it was new and have 21K on it now and have never throw that code, or any other code for that matter. I am hoisting the BS flag on this too
 

·
Registered
Joined
·
153 Posts
I had that code ... they replaced a sensor and cleaned the EGR, no more cels
 

·
Registered
Joined
·
1,689 Posts
Hey EsJayco, how do you like your flatbed?? This is the second one I have had from them and they have been outstanding!! If you can get the LED's they look great!!!



Sorry for the hijack
Chris
 

·
Premium Member
Joined
·
809 Posts
Discussion Starter · #10 ·
Update. Picked up the truck last night. They said I could bring it back this morning with factory box and they would erase code to see if it came back on. I said bs I have that intake on for over 20000 miles. So I went to auto zone had code erased and knock onwood it has not came back on yet.
 

·
Si vis pacem, para bellum
Joined
·
2,459 Posts
come back on yet? i have this code right now. taking the truck for appt on wednesday, they are gonna clean the egr. i will try and get them to replace that sensor as well. can anyone who's had this repaired shed any additional light as to which sensor needs replaced? thanks.
 

·
Premium Member
Joined
·
809 Posts
Discussion Starter · #12 ·
No it has not came back on yet. I am about ready to take on the burden of this beast by myself. piss on the dealer.
 

·
Registered
Joined
·
15 Posts
I just installed the bosst fooler and p403 was thrown. why is that??
 

·
Mr. Vehicle Destroyer
Joined
·
11,909 Posts
EGR POS SENS VOLTS TO HI.
Service dept. says that my afe stage II mega cannon or any open air intake will cause that code. They won't check for problem with egr unless I put factory box back on and bring back. What is yalls opinion. I calll bs. Said unhooking battery cables won't clear all codes. I asked him if they cleared them with starscan he siad yes so I'll see but I bet not.
The EGR Valve has two different voltages running through it. The command position is a +12 volt signal that can be commanded to any of the three position command pins on the harness. The +5 volt side is for the hall effect sensors that tell the ECM what position the EGR valve is in. These are both on the same circuit board. If you have a thermal event within the valve itself it is possible that the +12 command is bleeding over a trace on the PCB that it isn't supposed to over to the +5 side and causing this issue. It doesnt have to be a thermal event even, any debris in the motor itself could cause particles to bridge on the PCB triggering that code to be thrown. :thumbsup:
 
1 - 14 of 14 Posts
Top