Dodge Cummins Diesel Forum banner

Can't spool my twins on the dyno

715 Views 7 Replies 6 Participants Last post by  drunk on diesel
Hi Guys

Im looking for some advice. I was on the dyno this past weekend, and i couldn't get my bottom turbo to spool on the dyno. I regularly on the street light it up and i can hit 100PSI, on the dyno i maxed out at 55 psi. I dyno'ed 275Hp, when i should over 600hp almost 700hp.

My twins are hx40 with a ht60 bottom, its an auto a518.

I was thinking a tranny swap would be a good idea, or maybe i should directly feed my bottom turbo from my manifold.

And ideas would be great, im not sure were to go now.

CK
1 - 8 of 8 Posts

· Registered
Joined
·
364 Posts
If it is a load dyno then they can load it hard for you so that your turbos can come up.If it is a inertia dyno than you will have to ride the brakes so that you can put a load on the truck
 

· Registered
Joined
·
4 Posts
Discussion Starter · #4 · (Edited)
If it is a load dyno then they can load it hard for you so that your turbos can come up.If it is a inertia dyno than you will have to ride the brakes so that you can put a load on the truck
Its a peloaded dyno, i belive the rollers are 2000lbs.

I had my foot to the floor on the breaks, but the breaks dont help much since they suck!

I was hopping for some ideas, i maybe changing up my setup to spool it better?

Thanks
 

· Premium Member
Joined
·
8,859 Posts
its not your set up it was the dyno, try a different dyno out
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top