Dodge Cummins Diesel Forum banner
1 - 20 of 26 Posts

·
Registered
Joined
·
106 Posts
Discussion Starter · #1 ·
Hi Everyone,

I performed the 67,500 service with replacement of the CCV filter and cleaning of the egr and egr cooling system. Did the reset procedure of 2 brake pedal, 2 slow accelerator pedal within 10 seconds and key off. Have done this at least 5 times but the indicator still comes on.

Is there a different reset method I am unaware of? Is there something I'm missing?

Thanks much!!
 

·
Registered
Joined
·
106 Posts
Discussion Starter · #3 ·
Cannot get Perform Service Light to go off...

The procedure is slowly push the throttle 3 times in 10 sec.
Good Morning,

That particular procedure is to remove the "change oil" message. I tried that as well just to see, which it did not work either.

The procedure that everything I have found on multiple websites:

1) turn power on but don't start truck
2) Press brake pedal twice
3) Press and release the accelerator to the floor twice slowly within 10 seconds
4. Turn off power.

This procedure does not seem to be working for me...

Any other thoughts out there?
 

·
Go Packers
Joined
·
11,197 Posts
• Turn the ignition switch to the ON position. (Do not start the engine.)
• Press and release the brake pedal two times.
• Fully depress the accelerator pedal slowly two times within 10 seconds.
• Turn the ignition switch to the OFF/LOCK position.
The message should now be erased. You can also do your favorite dance afterward!

This is from Geno's garage, on the procedure of what your doing. Sound like you are doing it correctly. Are you turning the key to the OFF/LOCK position when completed?
 

·
Registered
Joined
·
106 Posts
Discussion Starter · #6 ·
Good Morning,

Yes... Doing exactly as stated...

the only thing I can think of is something is not right in the reassembly that is tripping the sensor to say I need to peform the service...

I don't know how I could install a CCV filter incorrectly...
 
  • Like
Reactions: MBevans

·
Registered
Joined
·
405 Posts
Good Morning,

Yes... Doing exactly as stated...

the only thing I can think of is something is not right in the reassembly that is tripping the sensor to say I need to peform the service...

I don't know how I could install a CCV filter incorrectly...
The service indicator is tripped by mileage. Try the procedure, but close all doors in the truck while doing it. When you are done and turn the key off, open the driver door, then you should be good. I had this situation happen with the oil change indicator and doing the door trick worked for me...
 

·
Registered
Joined
·
1 Posts
2008 Ram 2500. Perform Service came on at incorrect mileage. Did recommended trick many times - that did not turn it off. Finally a BRAKE service indicator came up. Had a cranked front caliper. Had a complete brake job done including new front calipers and rotors. Now Perform Service is gone !!!
 

·
Registered
Joined
·
86 Posts
FWIW, I fought the same message without sucess until I discovered the message was indicating that an Injector was leaking into the crankcase and over filling the Oil Reservoir. If the message will not clear there may very well be another issue.
 

·
Registered
Joined
·
335 Posts
FWIW, I fought the same message without sucess until I discovered the message was indicating that an Injector was leaking into the crankcase and over filling the Oil Reservoir. If the message will not clear there may very well be another issue.
Would that not throw a check engine code? The preform service light on the 4th gens is just a mileage counter from what I’ve been told.
 

·
Registered
Joined
·
86 Posts
3SEVEN4,

On my 2011 it did not throw any codes. The only reason I 'figured it out' was that after a complete chage out of Injectors, Conector Tubes and Cross Overs we did a final oil change and the error message went away.
 

·
Registered
Joined
·
4 Posts
I just changed the CCV in my 2016 and tried to reset the perform service indicator about 8 times; didn’t work. Then I got my wife to try...it reset on her first try. WTF? Must be sensitive to the speed that you stroke the brake or accelerator. 😆
 

·
Registered
Joined
·
13 Posts
This is correct dodge told me two times did not work tried 3 bam turned off after replacing ccv thank you
I performed this sequence around 15 times before I got the warning to clear. Warning came on about 67400 miles I replaced the ccv filter. I believe it is a matter of timing and pressure. Great relief to get it cleared.
2014 Ram 3500
 

·
Registered
Joined
·
6 Posts
• Turn the ignition switch to the ON position. (Do not start the engine.)
• Press and release the brake pedal two times.
• Fully depress the accelerator pedal slowly two times within 10 seconds.
• Turn the ignition switch to the OFF/LOCK position.
The message should now be erased. You can also do your favorite dance afterward!

This is from Geno's garage, on the procedure of what your doing. Sound like you are doing it correctly. Are you turning the key to the OFF/LOCK position when completed?
Trying this procedure about ten times on my 2014, I’m at 135k an I can’t get the message to reset
 

·
Go Packers
Joined
·
11,197 Posts
Trying this procedure about ten times on my 2014, I’m at 135k an I can’t get the message to reset
Not sure if this will help, but do you have the doors shut? When I reset mine, I got in and made sure the drivers side door was closed. Maybe someone else will have a better idea.
 

·
Registered
Joined
·
2 Posts
Just said something similar in another thread but I had the same message on my 2018, changed the ccv filter, couldn’t get the message to reset. Eventually check engine light came on too. It was my DPF pressure sensor failed. So maybe there is another issue that needs to be looked at.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Not sure if this will help, but do you have the doors shut? When I reset mine, I got in and made sure the drivers side door was closed. Maybe someone else will have a better idea.
This is kind of an old thread but I just got done going through this with mine I tried the door trick I tried doing it multiple times I tried doing the gas pedal three times the brake pedal three times both alternating twice for the brake three times for the throttle three times for the break two times for the throttle all different sequences what did eventually work for me was the two brake pushes and the two throttle pushes slowly has to be all done within 10 seconds it was a time issue so make sure the two brake pushes and the two throttle pushes slowly is under 10 seconds hopefully this helps
 

·
Vendor
Joined
·
15,046 Posts
Building Font Art Magenta Facade


Thank you for that post, it may help some members.
 
1 - 20 of 26 Posts
Top