Dodge Cummins Diesel Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
today I started my truck and the engine knocked harder then normal. Once i would accelerated the engine ran normal with and occational buck. I drove the truck for 10 miles then i disconnected the max mileage to ensure that was not causing the problem. The engine ran better i thought. It still bucked occationally. After driving one and half miles the truck shut off. I pulled over to the side of the road and tried to restart it. No luck had it towed to the dealership then i got it to restart. Anyone have any thoughts. Thanks
 

·
Registered
Joined
·
866 Posts
Sounds like you lift pump to me. Have you checked your fuel filter lately? It could also be a really clogged filter.
 

·
Registered
Joined
·
368 Posts
fuel filter..>shrug<
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #4 ·
fuel flter was replaced 200 miles ago
 

·
Premium Member
Joined
·
2,232 Posts
Who replaced the filter?
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #7 ·
yes only 14000 on the truck
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #8 ·
I changed it myself. I followed the thread posted on this forum
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #9 ·
it was the fuel rail sensor. the mechanic said that they go with no warning.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top