Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Cummins of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
2006 Dodge Ram 2500 5.9 Mega Cab
Joined
·
4 Posts
Discussion Starter · #1 ·
First post on here always been a long time lurker. Just bought an 06 5.9 that was running great when I got it after leaving my 6.4 power stroke days behind. Only ever owned ppumped 12 valves so I’m new to common rails. Currently been chasing this issue that makes the truck undrivable. After driving about 10-15 minutes on the highway in the morning my truck will begin to buck and stutter. Starts to dump black smoke and will calm down when let off the pedal. It’s a 50/50 chance that it will continue at lower speeds while accelerating. No codes thrown. Already replaced batteries, fca, and tested injectors along with the whole wiring harness. Never got above one ohm (have all new battery cables coming in tomorrow as well). Any help would be greatly appreciated I’m at my wits end with the problem
 

·
Registered
1999 Dodge Ram 2500 5 Speed 4x4
Joined
·
208 Posts
Have you tested rail pressure and lift pump fuel pressure?
 

·
Registered
Joined
·
3,749 Posts
Turbo actuator, Air filter, air intake boots, could be a bunch of things. Start with the easiest and go from there.
^^^^^ my guess
 

·
Registered
2006 Dodge Ram 2500 5.9 Mega Cab
Joined
·
4 Posts
Discussion Starter · #4 ·
I tested the lift pump and it was within spec. Fuel rail pressure was going crazy like saying 100k+ PSI. Just swapped out the sensor and am going to test drive it. Last night I drive it to test it and finally got a code. P0192. Hopefully it was just the sensor causing the issue. Will update as I find out more
 

·
Registered
2006 Dodge Ram 2500 5.9 Mega Cab
Joined
·
4 Posts
Discussion Starter · #5 ·
So update. Went on a 20 mile highway drive and felt low on power but didn’t buck and stutter this time. Drove it home then needed to leave again. Went about 3 miles down the highway and then the truck got a dead pedal and died. Tried starting it again but it’s a crank no start. Currently on the side of the road waiting for my friend to pull me to a parking lot to diagnose. Any ideas on what to check first?
 

·
Registered
2006 Dodge Ram 2500 5.9 Mega Cab
Joined
·
4 Posts
Discussion Starter · #6 ·
Snapped the flexplate. I believe it devolped stress fractures from how extreme the fueling bucking was. Just my luck haha
 
1 - 7 of 7 Posts
Top