Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
3rd Tranny/2nd Turbo Club
Joined
·
123 Posts
Discussion Starter #1 (Edited)
Well, i did it last week.. i broke my transmission. I was power braking, about to spin the tires, and i let off the brake and took off.. well.. my truck would not go past 3rd gear.. So, i drove to my house at 25 MPH and then had the truck towed to the dealer. The dealer dropped the trans pan and found lots of nice metal chunks. Gears/Clutch packs... whatever else is metal was in there.. lol.. So, its been a week now and i'm still waiting on a trans. They ordered one friday after they came off backorder status. Its coming from dallas, tx and should be here today or tomorrow.. Hopefully i'll have my truck back to work by Friday this week ! Oh, all i had on was the Edge on 6 when i broke it. I havent run the Edge with the Bullydog in probably 2 months. Just been leaving the Edge on 6 all the time. BTW.. truck has 25,600 miles.. Owned it exactly one year now.!
 

·
Where's my sparkplugs????
Joined
·
1,046 Posts
Ouch! Did the dealer question you about your mods? You'd think they'd check for them after they got a pretty much new truck in the shop with a trany tore up like that.
 

·
3rd Tranny/2nd Turbo Club
Joined
·
123 Posts
Discussion Starter #3
I had the Edge removed from the truck before i took it in... The EGR delete i did looks stock.. unless you pull off the EGR cooler itself. and as far as the DPF delete.. that won't smoke a tranny.. so they didn't care about it.
 

·
3rd Tranny/2nd Turbo Club
Joined
·
123 Posts
Discussion Starter #5
Well, here is an update.. I got my transmission fixed last week. Got the truck back on Friday, well.. for some reason my idle is off... and my exhaust brake quit working.. SO, i dropped it off on monday, and it appears i need a turbo now. Blowing oil into the intercooler and intake .. So, i guess i should be getting it back this week.. hopefully they figure out the funky idle. I know its not caused by the Edge because i took it off.. so must be something in the computer. Since i did get a new ECM a few weeks before the tranny took a sh*t.
 
1 - 5 of 5 Posts
Top