Dodge Cummins Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1 (Edited)
I' M Runing A Phantom Auto Meter 0-60 Gauge. It Vibrates Like Crazy At 25psi To 35psi,really Depend How Hard You Get It ,hold Better When Laying Into It. Ive Been Told That Its A Boost Leak But Cant Find One , But I May Be Looking In The Wrong Places. Wheres The Week Link?and Is There A Process I Need To Go Though To Find It , I'm At A Total Loss Here :cry:need Help
 

·
Premium Member
Joined
·
5,382 Posts
Did you use a "boost bolt" to do the install?

If so, you screw this component into the boost bolt and then attach the compression fitting. Adjust this valve until you get a reading and don't get the bouncing needle..

Needle Valve 1/8 NPT
 

·
Registered
Joined
·
57 Posts
Discussion Starter #3
Boost Bolt Installed, But Im Onley Geting The Vibration At 25psi To 35psi. Do I Need To Install Valve , Adjust , Then Go Out And Push Some More Air And Then Cont. Untill Problem Is Solved? I Also Have Auto Meter Sending A New Gauge Just To Help Me Trouble Shoot This Problem .them Auto Meter Guys Sure Now How To Take Care Of There Custermer Unlike A Lot Of Places In This Day And Time
 

·
Registered
Joined
·
57 Posts
Discussion Starter #4
can any body help with this? new gauge installed ,still the same , have not installed a valve yet.is this common practice? and what does it solve? or is there somewere else i need to look
 

·
Registered
Joined
·
57 Posts
Discussion Starter #5
need help asap
 
1 - 5 of 5 Posts
Top