Dodge Cummins Diesel Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
i installed k&N cold air intake, 5 inch exhaust 3 guage pod and just recently installed a #10 fuel plate and boost elbow drove for about 2 weeks had lots of fun with the extra power, but now my boost guage is not reading at all and the truck feels gutless. i am not sure how to check the wastegate, i was considering installing a big head wastegate, is this a good idea because i don't have the hx35, i have the wh1c turbo. any suggestions would be greatly appreciated.
 

·
Registered
Joined
·
10,854 Posts
check the intercooler boots for rips/tears/cuts. the lower boot on the passenger side tends to rub on the body sheetmetal and cut itself...

Could also be a fueling issue, plugged filter/prefilter/bad lift pump/afc line broke/ect...
 

·
Registered
Joined
·
1,132 Posts
:agree2: i 100% agree with dave. if you lost power all of a sudden and your gauge is not reading boost. look at the intercooler boot dave stated. it likes to blow a hole and as soon as that happens, you wont make almost any boost untill you get it replaced.


SOUNDS LIKE A BOOST LEAK
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
thanks any way

Didn't find any rips or tears in the boots. A friend helped me out that knows a little about diesels. we unplugged the wastegate, plugged off the line after the boost gauge just to try it, took for a quick drive got 28 psi of boost. He believes that my wastegate is either stuck open or torn inside not allowing to build boost. Does this sound right to you guys. What kind of wastegate will work with my factory WH1C turbo. (I don't have the HX35)

Thanks
 
1 - 4 of 4 Posts
Top