Dodge Cummins Diesel Forum banner

blown turbo

1615 15
I recently blew up my stock turbo on my 2005 3500. I also noticed that i had a crack in my manifold. I have replaced both of them with another stock set up I got from diesel dynamics. Now i can not get the truck to start. It spins and spins almost starting but it just wont bust off. anybody anywhere, please please help.
1 - 16 of 16 Posts

· Banned
Joined
·
5,760 Posts
Any codes?
 

· Registered
Joined
·
26 Posts
Discussion Starter · #5 ·
The exhaust manifold was cracked. The truck has strt. pipe with a valant cold air intake and a quadzilla xillaraider programer. Transfer pump is working fine. When it blew i was in the pedal pretty good with the chip turned all the way up. It made a noise like putting a black cat in a coke bottle on lost all power duped a load of white smoke and died. First time to blow a turbo.
 

· Cummins Fanatic/INJECTION PUMP TECH ADVISOR
Joined
·
419 Posts
Over boosted the turbo. Do you have any gauges on the truck? Boost or Pyro? If so what reading where you getting before she went?

Any idea what you rail pressure is while cranking? You may have a damaged injector leaking pressure into the cylinder.
 

· Registered
Joined
·
26 Posts
Discussion Starter · #12 ·
I dont have a pyro. guage but I am on the hunt, money is a little tight though. So if any body has one they want to get rid of holler at me. The latest is my beast is back up and rolling. replaced the cracked manifold and blown turbo with one I got from a local diesel shop(diesel dynamics) great shop and friendly dudes over there. helped me out a bunch. The manifold I got was off a 2006 with about 15000 miles on it. and tapped ready for my pyro guage. Truck is running great. None of the metal made it through the after cooler. luckily.
 

· Registered
Joined
·
26 Posts
Discussion Starter · #13 ·
One more thing. I know you should always where your seatbelt, but after I replaced the turbo, and this is gonna sound stupid. My seatbelt dings all the time now. well when Im not wearing my seatbelt. It never did it before. ever. The light would be on but it wouldnt ding. I have had both batteries out plenty of times before all this and It never made a difference. Any ideas. nothing new got plugged in.
 

· Registered
Joined
·
753 Posts
look in your owners manual. there is a way to turn the chime off described in the owners manual. but that is wierd how the seat belt chime is on now.
 

· Registered
Joined
·
250 Posts
It chimes because you unplugged the batteries to install your new parts. The computer lost the chime delete since you cant permanently reflash the firmwear without a computer.
 

· Registered
Joined
·
26 Posts
Discussion Starter · #16 ·
You said cause I unplugged my batteries, but I have had them out before at the same time for a lot longer than this time. but appreciate the tip on the chime delete, that thing is really loud and annoying. when it starts going off it, keeps going off every 5 seconds or so.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top