Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 17 of 17 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
so i have a problem, my 6.7 is having an issue. i have a power pup and self made dpf del. it has been running great for the last 10k or so with this setup. 20mpg avg and ive been loving it. so the other day as i pull into a ranch i've been working at it starts to run rough. i didn't think much of it as its a rough rough road going in there. then i got to the smooth part and it the motor was rougher. i reprogrammed the power pup back to stock and it was fine for about 20 miles and then the same rough running. its only rough about 950rpm up to 1900 rpm, other than that you can't tell. so i thought maybe i will try driving it a little hard to see if it helps so i got it up considerably above the speed limit :) and about 95 it made a funny noise and smoothed out 100%. drove like a champ for 40 miles and then right back to the rough stuff and its not been better since. i had been getting fuel wherever it was cheap so i got a new filter and pumped all the old stuff out then put 2 gals of new and pumped it out too, made sure it was clean. then started over and its still rough as hell.

anyone else have this problem?

the guy i work for called a dealer and told the svc mgr the whole deal and he said the power pup problably screwed with the wrong setting and messed up some algorithm in the ecm. i don't want to believe that though.

i need to get this thing fixed asap. i am going to put all the dpf stuff back on and get it set back as stock as i can get it. i talked to the guys at bully dog and they said dealer wont be able to tell anything about it having a programmer. so once i get it all back stock and drive it round the pasture in the rain a few times(prays for rain) i guess i will take it in to hopefully get it fixed. onle code i got so far(idle only after clearing codes) is 0037. could the front 02 sensor getting clogged cause this?
 

·
Registered
Joined
·
838 Posts
mine did that with the emissions garbage, wouldn't hardly run at all, had to run it over 2500 rpm just to get it to the dealer... but with the dpf delete, i don't know... what did your boost pressure look like?
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #3 ·
the guage got a hole in the tube the other day so i don't know. had to cap it off.
 

·
Registered
Joined
·
838 Posts
when the dealer fixed mine they didn't tell me what the did, but i'm assuming they cleaned the turbo, and i know it got a reflash, it would sputter a little untill they did the g30 recall, but since the dpf and egr delete, i haven't any issues.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #5 ·
i am wondering if the egr has anything to do with it
 

·
Registered
Joined
·
838 Posts
with the egr and no dpf mine would surge real bad in 6th gear at 2000rpm. have you checked connections on your fooler box?
 

·
Registered
Joined
·
565 Posts
when the dealer fixed mine they didn't tell me what the did, but i'm assuming they cleaned the turbo, and i know it got a reflash, it would sputter a little untill they did the g30 recall, but since the dpf and egr delete, i haven't any issues.
Cleaned the turbo? :lol3:
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #8 ·
i checked my wires today. all looked good. mine is just a home made deal but voltages checked out good. mine never surged or anything before. i do need to get a new flash though, mine hasn't been near a dealer since november
 

·
Registered
Joined
·
838 Posts

·
Registered
Joined
·
137 Posts
my truck is completeley stock and this happened to mine. i took it to the dealer they told me it was from the egr putting sout into the turbo and butterfly vaulve getting stuck so they cleaned the vaulve and put a new turbo on. it runs fine now
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #11 · (Edited)
so could i just clean the butterfly valve or should i just take it in? this thing is costing me right now for loss of use, need to haul a tractor and a backhoe this week and next.
 

·
Registered
Joined
·
838 Posts
i'd try to clean it first, but it's costing you money it may wind up being better to just hit the dealer right away.
 

·
Washington Chapter Vice President
Joined
·
5,055 Posts
Get that EGR off there and your down time will be reduced significantly
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #14 ·
it is throwing these two codes right now, dpf is in place. i took the o2 sensors out and wiped and blew them out. could it be a fuse? grrr. guess it will be going to the dealer after all. was going to try cleaning butterfly today but i didn't want to mess with the blue markings on every bolt up there before i took it to the dealer.


P0031-o2 Sensor 1/1 Heater Circuit Low
P0037-o2 Sensor 1/2 Heater Circuit Low
 

·
Washington Chapter Vice President
Joined
·
5,055 Posts
Dealer is where i would go.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #16 · (Edited)
its at the dealer. when i pulled in the "diesel guy" came out and checked the codes and it said cyl 6 missfire and o2 1/2 heater low. i mostly acted dumb, he said they have a protocol where they drill the turbo and use a flush to clean the particulate system out and stuff, just like most of the dealers are doing that don't want to replace the turbo. they run 3 regens on it at this dealer. he said with the cyl 6 code he was gonna put a new injector, replace egr(its blowing soot out of the exhaust side valve where the cable wraps arround). new o2 sensors, iat sensor, etc etc. they said they have a 6.7 in there with an inch of soot built up in the tail pipe.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #17 ·
got it back, runs differen't, more like a diesel should, not buttery smooth like before, maybe a pcm update. they replaced an injector and wanted to charge me to flush the other injectors, i said no. talked to a guy who just got his second full set of injectors a few days ago.
 
1 - 17 of 17 Posts
Top