Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Cummins of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
In the morning, I have been having problems with my speedometer, tach and it not charging, and no overdrive,
Drive it for about 5 mins and everything starts to work

Was finally able to troubleshoot it one morning, with everything not working, I dont have the 8 V input to the circuit, couple mins later, everything starts to work, and I have 8.8 V at the pin,
This leads me to believe that the Crank position sensor isnt bad after all, but whatever feeds it power is,

I am assuming the PCM?

If so where is the best place to buy one ?


Thanks for the help

Eric
 

·
Banned
Joined
·
624 Posts
Eric, one of the guys on TDR just replaced his. I'll get the place and let you know.
:beer
 

·
Registered
Joined
·
1,862 Posts
Before I started throwing parts at it I would check all wiring and connectors, including all grounds. You want to check for voltage drops in the various circuits. A very large percentage of PCM replacements turn out to not be the problem and they are not returnable.
The fact that it is intermitent would make me suspect a connection somewhere and not the PCM.
Steve g
 

·
Registered
Joined
·
1,154 Posts
I do not have much experience with working on pcm's but I remember when I worked at Big A auto parts alot of people would buy a computer and plug it in. If it did not fix the problem they would try and return it. SORRY, NO RETURNS ON PCM,s
 

·
Registered
Joined
·
1 Posts
I'm having the same problem on my 00 cummins. All of my gauges sometimes do not work and some dummy lights come on. I've checked all of the fuses and still can't find the problem. Please help!
 

·
Premium Member
Joined
·
103 Posts
Me tooo..........

I have the same problem with my altenator........ sometimes it will just stop charging. I have had it bench tested and it checks out fine.

I am going to check all the connections and grounds this afternoon and see what I find..........:thumbsup
 

·
Registered
Joined
·
42 Posts
I am having the same problem with voltage dropping and every once in a while it will spike and turn on the check engine light, the code is for an over voltage. When I first start it, it seems to be fine (don't get the voltage drop on the gauge) after it heats up the gauge starts dropping when I come to an idle and the radio will start going on and off. I believe the voltage regulator part of the pcm is bad. I had the same thing happen on my 91 Dodge van years ago. I changed the pcm and all has been good since. I will be buying a pcm soon for mine. So I too could use the name of any place that sells them. Does anyone know if Ma Mopar still carries them?
Thanx, Clay
 
1 - 8 of 8 Posts
Top