Dodge Cummins Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
270 Posts
Discussion Starter #1
Seems to be a steady stream coming out somewhere around/behind the engine mount on the drivers side of the engine.

Any idea where that would be coming from? What is in that area that would leak that bad. Seemed to start all of a sudden. I did just have the transmission cooler lines replaced a short time ago, so maybe they knocked something loose.

Appreciate any help.
 

·
Registered
Joined
·
2,948 Posts
The turbo drain is over there. It drops back into the block thru a dedicated port just above the where the pan meets the block in the vicinity of the engine mount IIRC. Might be the turbo drain got knocked loose. That end is a press-fit with an o-ring I believe, so it’s entirely possible if someone was working in that area they could’ve knocked it loose and not realized it.

Hope this helps.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
819 Posts
Uh, on my 07' 5.9 the turbo is on the passenger side.
 

·
Registered
Joined
·
270 Posts
Discussion Starter #4
Thanks guys.

Yes, my issue is on the driver’s side. I believe there is a drain from the valve cover to an area behind the ECM, so it could be that. There also appears to be a sending unit of some kind in the block behind the fuel filter, so that could also be it. Does anyone know what that is for?

Those are the only 2 spots that I have found through YouTube videos and diagrams that look like they could be the culprits. The older Cummins had a tappet cover in the side of the block, but I think that’s no longer there on the common rail.

Anyone ever have an oil leak issues with either of those?
 

·
Registered
Joined
·
2,948 Posts
Sorry; brain fart. I got the Reft and Light cornfuzzed.

I iz edjamuhkaturd...


Sent from my iPhone using Tapatalk
 
1 - 9 of 9 Posts
Top