Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
733 Posts
Discussion Starter · #1 · (Edited)
I need some input and fast, also I pre apologize for this is going to be a long post. I had the Edge Juice with Attitude installed two weeks ago (the Edge shows a mfg date or 07-2007) at a reputable off road / performance shop. I drove close to 150 miles with it over a period of a few days on level 1 and twice on level 3.

On Friday I hooked up my toy-hauler (11,400lbs) and set the Edge to tow level 2 and away I went. After close to 80 miles with no problems the truck started to shake and loose power big time, then the red lighting bolt and CEL light came on. Lucky for me I was only about 3 miles from the dealership that I use. I got off the hwy and checked the Edge for codes and it said P0204, P0205,P0206 open circuit fuel injectors.

I pulled into the Dodge dealership and they scanned it, and said my Edge had shut off the fuel to those three cylinders. The mechanic unplugged the Edge and re-plugged in the stock harness and cleared the codes and the truck ran normal again. His opinion is the Edge is bad and I need to have it replaced, and then I was told that I need to get the “A” flash done. The dealer was cool about the mods and said once I get the Edge replaced, to bring back my truck and they would give me the new flash. They didn’t charge me and I was at least able to continue my trip for the weekend.

My question is, has anyone had this happen or did I just get a bad Edge unit? I called the place that installed my Edge, and the manager was sorry about the situation and said he would order a brand new unit and install it on Wednesday as soon as it arrived. My BADP DPF Delete kit is scheduled to arrive tomorrow and I most certainly want the Edge to be up and running to clear the codes that the DPF delete is going to throw.

Do I need this new flash the dealer is talking about, and what does it do? The only time I've had my truck plugged into at the dealership was back in November when I got the G-30 O2 sensor recall notice in the mail, so I don't have a clue what flash I have. Thanks for the input….
 

·
Premium Member
Joined
·
8,550 Posts
I know of one truck that did the same thing here with the edge it was a 5.9 but the edge we think cut half the cylinders like in your case and it burnt the motor up because they kept driving it, the dealer replaced under warrenty but they sell performance products also so they warrenty most work. Other than you and my story I have not heard of any problems but there are two injector plug ins and it could possibley have came loose alittle who knows
 

·
Registered
Joined
·
331 Posts
I would vote for bad connection in one of the injector plugs. Get some dielectric grease and re connect your injector plug-ins and check the wires going into the back of the plugs make sure the shop that put it on didnt mess something up. I would also have maybe looked for a new edge or asked for one. The mfg date of 03/08 has the timing adjustment. If you have to get a new one I would ask.
 

·
Premium Member
Joined
·
2,902 Posts
Call edge and talk to them, Hope you payed the right price for it too or you may not have a warranty
1-888-360-3343
John:thumbsup
 

·
Registered
Joined
·
733 Posts
Discussion Starter · #5 · (Edited)
The shop that installed it, does alot of work for our work trucks (Border Patrol) so they were more than willing to just order me a new one I'm in there alot with our truck besides my own POV. I was surprised that when I got it, it was mfg in 07-2007.

I hope the new one will be a newer version with the timing feature. The Dodge mech said it could be the wiring harness and not the actuall box, but I'm scared to hook it back up and drive around if it does it again, I'm 128 miles from the dealership with no way of clearing the codes and resetting it back to stock.
 

·
Registered
Joined
·
733 Posts
Discussion Starter · #6 ·
Edge contacted me and said it was likely the module, and they gave me a number to give to the dealership that installed it so they can get credit from Edge and I'll be getting a brand new one this week! I hope I get one of the 2008 models that has the timing feature.:thumbsup

BADP exhaust arrives tomorrow! Yahoooooo!:peelout
 
1 - 6 of 6 Posts
Top