Dodge Cummins Diesel Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
Hey guys, I am having same problems with my '99 transmission that I also had with my '02.

When cruising in 4th gear (Auto transmission) it slips out of 4th and I'm assuming into 3rd. It doesn't stay in 3rd though, it does this slipping thing multiple times until I either increase speed or increase RPM's.

An addition to this problem is, it is now doing this on the freeway at speeds of 65-70 mph, BUT when it slips out of 4th into 3rd it stays in 3rd until I mash the throttle and get up to about 80 mph. My '02 never did this on the freeway.

Does anyone have any clue on to what is going on? My truck is stock other than a FBD 4" straight pipe. And it has about 115,000 miles on it, with the tranny being replaced by the dealer at 15,000 miles.

Thanks,

Matt
 

· Registered
Joined
·
1,420 Posts
Well it could be your TPS. Mine did the same thing and the TPS was to blame.
I know your frustration about nobody answering even though you see people have looked at your thread.
 
  • Like
Reactions: arcticsnoman

· Registered
Joined
·
662 Posts
It almost sounds like the APPS noise problem but it's happening at too high a speed. Usually the APPS problem happens at right around the lockup speeds of 3rd and 4th.

The problem with remote diagnosing something like this is that it could be any number of things from slipping clutches to valve body issues.

Sometimes the best solution is to take it to a reputable shop for diagnosis.
 

· vvv SOME PEOPLE'S KIDS vvv
Joined
·
14,088 Posts
my problem ended up being the main power wire on the back of the alternator was shorting out the power to the transmission controller
I've heard that was one of the issues as well..
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top