Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Have any of you seen a CEL with your Edge clearing codes at startup. I have a code P0472 even with the Edge. The Edge reads Engine Exhaust Pressure Low Sensor 1. I have also seen my Engine temps rise to about 210-215 when idleing. Is this normal ? What would you all suggest.
 

·
Premium Member
Joined
·
713 Posts
Have any of you seen a CEL with your Edge clearing codes at startup. I have a code P0472 even with the Edge. The Edge reads Engine Exhaust Pressure Low Sensor 1. I have also seen my Engine temps rise to about 210-215 when idleing. Is this normal ? What would you all suggest.
Sound like your particle filter is pluged up, time to see the dealer for a manual regen.
 

·
Premium Member
Joined
·
8,550 Posts
just drive the heck out of it on the highway or free way to heat up the exhaust to burn everything out, if you know some one with a power pup then borrow it and use the mobile desoot function to clean it out, all else fails strait pipe it
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Kinda what I thought. Bit worried about taking her in to the dealer with the Edge temp guage drilled in the side of the exhaust manifold. :$: What is the exposure to not fixing it immediately? Thinking of BADP but would like to wait for Code free.
 

·
Premium Member
Joined
·
713 Posts
Kinda what I thought. Bit worried about taking her in to the dealer with the Edge temp guage drilled in the side of the exhaust manifold. :$: What is the exposure to not fixing it immediately? Thinking of BADP but would like to wait for Code free.
Could buy an Insight and hook it to your thermocoupler. :thumbsup
 
1 - 5 of 5 Posts
Top