Dodge Cummins Diesel Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
15 Posts
Discussion Starter · #1 · (Edited)
Air Dog quit working - Update 6/4 - Running, but rough - FIXED!

Update - Got 2 P1689 codes (1 active, 1 pending) and now have a stumble you can really notice at idle (but is there throughout). I am going to go crack the lines while running and see if I get air.


Air dog FP150 installed 3 months ago, driving down the road and noticed a stumble at 60, progressively got worse, and ultimately died (ran out of fuel). Tank is 1/2 full, air dog isn't kicking on at all, fuse is good. Any ideas?
Scott
 

· Registered
Joined
·
817 Posts
Do you have a fuel pressure gauge? Bump the starter and listen for the pump running and let us know. Might need a new relay, but check all your connections to the pump. Also check your codes with the key trick (on off on off on and leave on, watch odometer)
 

· Premium Member
Joined
·
2,799 Posts
i have had the oem ecm connection go bad before and the pump wont get power to the relay. you can hook it up to key on power and see what happens. it fixed mine
give us a call if we can help

John:thumbsup:
 

· Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
Well, wiggled the connections around and she fired up. Got a P1689 code and now have a stumble you can really notice at idle (but is there throughout). I am going to go crack the lines while running and see if I get air.
Scott
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top