Dodge Cummins Diesel Forum banner

41 - 60 of 67 Posts

·
Registered
Joined
·
765 Posts
Discussion Starter #41
be the first to review it on the afe website...(if they have reviews) else, reciew it from where u bought it.

that is total crap that things dont line up


I’m going to email carid and complain about the shipping box condition. And yeah I’ll be letting afe know about the figment issues.


Sent from my iPhone using Tapatalk
 

·
TECH SPECIALIST
Joined
·
11,183 Posts
I’m going to email carid and complain about the shipping box condition. And yeah I’ll be letting afe know about the figment issues.


Sent from my iPhone using Tapatalk
agreed on afe knowing but the next guy needs to know as well... with all the issues you showed, i would have sent it back...
 

·
Registered
Joined
·
765 Posts
Discussion Starter #43
agreed on afe knowing but the next guy needs to know as well... with all the issues you showed, i would have sent it back...


I seriously debated to. I hate it when new stuff doesn’t fit or you have to mod them to make them fit . Maybe I just got a dud... I don’t know it looks really nice but it sure doesn’t fit real good . It looks like it’s going to work now . But if I run into anymore problems I probably will send it back. Based on my past experiences with similar stuff like this. Usually in my case the replacement isn’t any better or is worse .


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
765 Posts
Discussion Starter #44





There you go steve, I get 3 and 1/2 with the afe in there.
Every thing appears like it’s going to work. Only thing I haven’t tried is to put the fan back on with the shroud on. That’s next.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
765 Posts
Discussion Starter #45
Well it’s in... for better or worse it did fit not with out making it fit . Will fine out I guess if the cooling performance is any better . Now all I need is to find out it leaks...


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
2,592 Posts
Thanks for the information and review! :thumbup: Like you, I find it inexcusable to have to work on a "brand new drop-in" item, just to make it work. After all the aggravation, I hope it works well for you :thumbup: It would totally suck, to go through all that, and then have issues with it, on top of everything else.
 

·
Registered
Joined
·
765 Posts
Discussion Starter #47
Well drove around with the rad install and it didn’t blow up or leak . Hard to say on how it’s performing compared to the oem. But I do believe it cools better . I got on it a few times and before the temp would go up to about 205 and then back down . Now it just sets there and barley moves . I also replaced the junk napa thermostat for a cummins brand one so that also could have helped . The real test for it would be to tow the 5075e and take it out to the other farm. Lots of hills to clime going out there . But I really have no reason to take the tractor out until it needs mowed . I did notice that once the truck is up to temperature. The rad smells really odd. Like burning plastic odd.. If I didn’t know it was the radiator I’d think i had something burning under my hood. Maybe it’s left over smell from the tig welding gases ? Not sure .

Also I stopped buy the shop that worked on my trans and they had some bushings for the upper core support. They are discontinued , I called up the dealer and they can’t order them. But shop owner had some and give them to me . He asked me what I did about my leaking radiator I told him I tried the afe and was very disappointed with the fit . He said he had a customer bring one in and it was a pos . At frist he thought it looked like a good radiator, but then like me they had trouble with the upper core support brackets on the radiator not wanting to line up like I had. He said it took his engine guy a extra two hours cause of the Fitment issues. And the engine guy said that was the most annoying and aggravating job he’s done .. and he spends all day removing cummins engines and building them plus removing transmissions . So I guess I’m not the only one with that had problems.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
765 Posts
Discussion Starter #48
Well, it appears that I’m going to be able to test how well this radiator works . Saturday I’m going to (weather permitting) be pulling a case 580 super e backhoe. According to tractor data it weighs 10 to 11 k. Soo that should be a pretty good load . Definitely be interesting to see how it performs


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
765 Posts
Discussion Starter #49
Didn’t tow the backhoe . It was a case 580k with a extended a hoe . Weighed 17,000 pounds not including the filled tires . That’s way to heavy for my trailer. And more then I’m comfortable towing .
It’s to bad it wasn’t lighter would have been interesting to see how well the radiator performed .


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
765 Posts
Discussion Starter #50
Wanted to update this . So far the radiator is doing good . I noticed as I was backing my 24 dove tail trailer in its spot . The trans started it get hot , got up to 180 but just sat there . The coolant temp got up to about 205 and drop back down to 190 once I got back in the truck after disconnecting it from the trailer . That seems like an improvement to me . Before I would turn my ac on just to get the fan to kick on to help it cool off , but it seemed to do that on its own . I also wanted to add some pictures that a lot of people would probably like to know before they buy one of these radiators ..... that is if they still want one after all the problems I had with it lol.



Afe has no provisions for the factory trans oil lines . Not a big deal for me since I have rubber lines that are routed different due to the mishimoto trans cooler . But I think they really should let people know that ahead of time . Once nice thing about the bracket being smaller is , it’s a lot easier to install and remove the radiator since it smaller and doesn’t want to catch everything as you pull it up and out .




One thing I like it uses the factory radiator cap. The eBay specials and mishimoto does not . I’ve read those caps aren’t the best either. It came with a 19 psi cap but I didn’t use it . Felt very cheap .



No crappy plastic end tanks. Also end tanks are very beefy . I like that part.



They also changed the nipple that Connects to the over flow bottle hose . It’s very sturdy brass instead of thin aluminum that someone reported it broke off . This is very solid and fits over the hose very nicely . Better then oem in fact. Only thing I wonder if galvanic corrosion will set in since it’s brass and aluminum. I put a lot of pipe dope on the threads to help prevent that . The drain is also brass . I do like how they positioned it , it’s on the end tank pointing straight down and even has a fitting on it to slip a hose over it . That’s nice feature. I forgot to get a picture of it I’ll get one tomorrow.





There’s looking down the filler neck. You can see the 3 row cooling tubes . I believe they are 16mm best I could Measure. The factory seems to be 3/4 or about 19 mm. Ok so doing some maths . My old rad is a two row with with 18.6 mm tubes or a little under 3/4 of a inch . That's 0.73 of a inch . So 0.73 times two is 1.46 inches of surface area.

New rad is just a hair over 16mm best I can tell . That's 0.64 of a inch. 0.64 times 3 is 1.96 of a inch so basically 2 inches . So it is definitely bigger but uses slightly smaller tubes which is disappointing. But theoretically it should cool better how much I don't know. Afe was claiming up to 30% I believe . It would have been better in my opinion if afe had used a two row with bigger cooling tubes .







Definitely bigger then factory.







Over all I believe it is better then factory, it does look great . I love how it looks under the hood . But given the problems I had with fitment I couldn’t recommend it to anyone . Maybe I just got a dud I don’t know . But given the fact my local diesel shop also had one with the same fitment problems. I’d say it wasn’t just me . So if you don’t mind to have to bend and trail fit something several times that’s supposed to fit out of the box .. then order one . If your like me and get infuriated when you have to make something work( seems like a trend now days) that was supposed to work out of the box in the first place . Then maybe stick with factory replacement or save up and get the griffin radiator. Real test will be to tow something with it. That will come later and I’ll update when I get a chance to.


Sent from my iPhone using Tapatalk
 

·
TECH SPECIALIST
Joined
·
11,183 Posts

·
Registered
Joined
·
765 Posts
Discussion Starter #52
thanks for the details! pics look great.


i did the math from the numbers you provided, you want to know the circumfrence of the tubes...

the afe has a circumfrence of 6.0 for the 3 rows, the stock rad was 4.6 for the 2 rows...

here is the calc i used ..

https://www.calculator.net/circle-calculator.html?radius=&diameter=.73&circumference=&area=&ctype=1&x=59&y=16

https://www.calculator.net/circle-calculator.html?radius=&diameter=.64&circumference=&area=&ctype=1&x=50&y=12


Interesting info Steve. So it is quite a bit bigger then. Probably why I’m seeing it hold temperatures longer with out spiking.


Sent from my iPhone using Tapatalk
 

·
TECH SPECIALIST
Joined
·
11,183 Posts
Interesting info Steve. So it is quite a bit bigger then. Probably why I’m seeing it hold temperatures longer with out spiking.


Sent from my iPhone using Tapatalk
Thats definitely a plus (spiking temps under control). While researching cooling systems I came across a good writeup about the cooling tubes and the flow thru them... never thought about this but the tube should have turbulence in it to maximize the amount of coolant contact to the tube. Not sure how they implement that one.
 

·
Registered
Joined
·
765 Posts
Discussion Starter #56
Well this is real cute... afe I think is censoring my review. I posted on there site a little over a week ago and it’s not showing up. I’ll post other one just to be sure it’s not a glitch. When I emailed them they asked for pictures and said they would pass it along to there engineers.


Sent from my iPhone using Tapatalk
 

·
TECH SPECIALIST
Joined
·
11,183 Posts
Well this is real cute... afe I think is censoring my review. I posted on there site a little over a week ago and it’s not showing up. I’ll post other one just to be sure it’s not a glitch. When I emailed them they asked for pictures and said they would pass it along to there engineers.


Sent from my iPhone using Tapatalk
Possibly but please remember... they are in Cali and on a stay in place order and may not have full staff and full functions. There have been a huge amount of layoffs nation wide and I would not doubt that some of the smaller businesses will be effected by the COVID-19 virus.

In these times of COVID-19... cutting some slack to businesses is in order.


For everyones info... data links & thread

https://www.cumminsforum.com/forum/off-topic/2526707-covid-19-how-bad.html#post29268937
 

·
Registered
Joined
·
765 Posts
Discussion Starter #58
Possibly but please remember... they are in Cali and on a stay in place order and may not have full staff and full functions. There have been a huge amount of layoffs nation wide and I would not doubt that some of the smaller businesses will be effected by the COVID-19 virus.

In these times of COVID-19... cutting some slack to businesses is in order.


For everyones info... data links & thread

https://www.cumminsforum.com/forum/off-topic/2526707-covid-19-how-bad.html#post29268937

That could be but I posted the review on the 15th I don’t believe the stay at home order was ordered then I could be wrong I that. I do recall I believe California was one of the first states to Oder the stay at home oder. Anyway I’ll give afe the benefit of the doubt and resubmit the review or maybe it’s best to wait until all this Covid-19 mess is over .


Sent from my iPhone using Tapatalk
 

·
TECH SPECIALIST
Joined
·
11,183 Posts
That could be but I posted the review on the 15th I don’t believe the stay at home order was ordered then I could be wrong I that. I do recall I believe California was one of the first states to Oder the stay at home oder. Anyway I’ll give afe the benefit of the doubt and resubmit the review or maybe it’s best to wait until all this Covid-19 mess is over .


Sent from my iPhone using Tapatalk
Yeah they went on SAH order on the 19th, but here in washington we went on SAH order on the 25th, we've been working form home for 2 weeks already. Pro-active employers got a jump on it. I would wait until things get back to normal before re-submitting it. From a business stand point, processing a review at this time might not be a high priority.
 

·
Registered
Joined
·
1,128 Posts
Nope, has zero to do with COVID-19. A product I purchased from them, and didn't even write a bad review on, it was neutral, still doesn't have the review 2 years later and I tried submitting a couple times.
 
41 - 60 of 67 Posts
Top