Dodge Cummins Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
After 35 yrs of Fords, I just bought a new to me 05 3500 DRW, and l have driven it 600 miles. It sat 2 days in freezing temps, and when I went to start today, batteries dead. I charge the bats, and when started, the MIL light comes on and pops the 2146/49 codes. It idles and revs fine, but I havn't driven it yet. It came with a Juice/Attitude, and searching the forum shows this may be part of the prob. Should I drive it some and see if it clears up, or disconnect the Juice? Did the dead batteries cause something to need re-setting? Any help much appreciated..
 

·
Registered
Joined
·
2,986 Posts
Those code very well could have come from the batteries losing their charge. Both are code for the injector voltage. Be sure all battery connection are good and corrosion free. Make sure the grounds are tight and making a good connection. You could need a new set of batteries and if it's real cold, using the block heater will help a lot.

I'd disconnect the Juice until you have it straightened out.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
thx triton,
it must have been the batteries, as I drove it about 60 miles with a few stops, got home and turned it off, and when restarted, the light went out..
fingers crossed:confused013:
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
thx triton,
it must have been the batteries, as I drove it about 60 miles with a few stops, got home and turned it off, and when restarted, the light went out..
fingers crossed:confused013:
 
1 - 4 of 4 Posts
Top