Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 14 of 14 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
I just installed a adrenaline, and the truck won't start, doesn't read the dash gauges.. I NEED HELP! I looked over the connections again, and they all look good.. did I go wrong somewere? HELP!!
 

·
Registered
Joined
·
70 Posts
Discussion Starter #3
found the under hood fuse for engine control2 20a is blown. going to store now for another.. all the adrenaline is unhooked, but the fass pump is not cycling, i'll see in a few minutes if replacing this 20a fuse will at least start the truck w/o adr hooked up....
 

·
Registered
Joined
·
470 Posts
No Justin you can't have your TST back. If you need any help give me a shout, don't know what I can do from here but maybe advice or suggestions. I knew there was a Adrenaline in your future, Slippery slope.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #6
the fuse in the side panel are good, i replaced the engine control relay, and now i have the gauges and pump working, but i need to crack open the injector lines now i guess since i tried starting it without the fass running. I just need to have it running soo..
 

·
Registered
Joined
·
70 Posts
Discussion Starter #7 (Edited)
well, maybe i'm not bleeding the injectors correctly, but i still can't get it to start. I had tried different lines, but i got a tiny bit of fuel through a few of them.. still no start. Ain't this some BS?
I would still like to know what happened with the engine control2 relay.. doesn't make any sense. I had the batteries unhooked while connecting plugs and connecting the fuse tap.. didn't hook the batteries back up till after everything was done. The data link was connected, the MAP was good, pump wire connected, grounded to the battery, and power hooked up. even the oil temp.
 

·
......................... .....
Joined
·
2,798 Posts
first bleed the VP44 at the return banjo. crack the banjo open, cycle the key to on, then blip the started, FASS should run for 30 seconds, once fuel starts dripping out close it up.

i would try firing it up then.

does the adr tap into the VP44? im pretty sure it does, check to make sure the right wire is tapped.
 

·
Registered
Joined
·
470 Posts
Justin loosen two or three lines, just bump your starter do not crank, fuel pump should run for about 25 sec, do this 2 or three times. then crank engine if it starts tighten fuel lines.
 

·
......................... .....
Joined
·
2,798 Posts
are you sure you want the line cracked when you try to start it........ sounds like 3500psi of diesel everywhere under your hood.....
 

·
Registered
Joined
·
470 Posts
Lines just cracked, not disconnected.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #12
still no firing this morning.. cycled it several times over, bled 3 tubes, 4 and 5 seem to bleed good, 1 not so much. I'm sure it'll start, but I have no time now. I'll be back after work to see what I can do.. But I still need answers somewhere on why my main engine control2 went out. This is cornfusing.. The ADR pod lit up, and displayed what it should, but killed the truck ( the relay/fuse ).. AHHHHHH!!! It's gonna be a great day.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #13
well quadzilla didn't call me back, so I called again, and they say that I should reflash the computer... don't know how this would cure a 20amp fuse blowing....
 

·
Registered
Joined
·
70 Posts
Discussion Starter #14
nevermind guys... my truck is dead. Not much fuel coming to the injectors now. Guess it'll towed somewhere now.
 
1 - 14 of 14 Posts
Top