Dodge Cummins Diesel Forum banner

A/C turn warm and humid after 20 minutes of cold?

1084 Views 8 Replies 7 Participants Last post by  derherr65
My air conditioner seems to be freezing up. It will run for 20 minutes then suddenly become semi-warm and humid. If I shut it off few 2-3 minutes it will begin running cold again... for a little while. What causes this? How can I fix it?
1 - 9 of 9 Posts

· hydraulic lifter crew
Joined
·
13,325 Posts
i went and bought a recharge kit - a/c system took both cans. seemed to help the issue a thousand percent. would try this 1st.
whats good is that you get to keep the guage and hose for next time.
it was around $40 out the door at autozone.

 

· Mopar1973Man.Com
Joined
·
26,034 Posts
Here is my write up on A/C...
Untitled 1

(I need to finish it...) :w:



Only need about 2 can from dead empty...


 

· Registered
Joined
·
352 Posts
Your metering device may have a problem. Its pry letting too much refrigerant into the evaporator causing it to flood and freeze over.
 

· Premium Member
Joined
·
4,719 Posts
i'm assuming you've checked your filter... always first on the list. and second would be blower amperage, third charge, fourth i would look at metering device (look for first point of frosting, and lastly a restriction in line. if your filter was plugged it would be constant freeze up, if your charge is low a freeze stat would cut it out periodically. same with a weak, under amped motor. restrictions are easy to find as well as metering device, as long as you can see beginning frost build, but not so easy to fix.. good luck

todd
 

· Registered
Joined
·
44 Posts
I would check to see if the compressor is engaged when the ac cuts out. I have seen the compressor clutches fail, they are fine cold but when they heat up it will not engage.
 

· Registered
Joined
·
206 Posts
Discussion Starter · #8 ·
Filter? I have a filter? Oh dear. :w:

Temps are running in the 90's here, but humidity has varied widely.
 

· Registered
Joined
·
206 Posts
Discussion Starter · #9 ·
New finding. On max A/C there is no problem. Stays cold, warms somewhat when stopped, then goes back to full chill when moving again.

As for the filter, unless you are referring to the orifice tube, I cannot find a filter.

I'm tempted to put a blue LED in the A/C control linked to the compressor, just to know when it's on.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top