Dodge Cummins Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter #1
I bought an old box 98.5 24 valve. It had a "bad" injection pump on it so the guy let it sit for 2 years. Long story short, I bought it for next to nothing. I found a used injection pump to make sure the truck runs. We swapped pumps and boom, fired up. The lift pump was not putting out great so I changed that with a ty unit. Now for some reason, the lift pump will not activate when the truck is being cranked. When you let off of the key, the pump comes on and fills the filter housing, but will not run while it is cranking. There is no check engine light. I am trying to find a scan tool to see if there are any codes but so far no luck. I have a smarty for a common rail but I assume it will not read the codes. Any help is appreciated.
 

·
Registered
Joined
·
1,348 Posts
Does the lift pump run when you bump the starter? The lift pump should run for 25-30 seconds if you bump the starter and then turn the key back to off or accessory position?

Does the Wait to Start light come on appropriately when you first try and start the truck? Even if it's warm outside, over 60*, the WTS light should come on momentarily. If the ambient temp is cooler than 60* the WTS light should come on and stay on to for some amount of time while the grid heater does its job.

If the WTS light is not coming on and the lift pump is not running when you bump the starter, I would lean towards looking for an ECM. Any chance you have a friend with a 24V VP truck to borrow off of? ECM's failing is a known issue for these vehicles given their age and especially if there are or were electrical issues (look up threads on bad alternator diodes and especially for automatic's, gear hunting is an issue).
 

·
Registered
Joined
·
110 Posts
Discussion Starter #4
The WtS light comes on. If the ecm is going bad, would the check engine light come on or would it at least store a code?

I do not think the pump is running while cranking. I can feel the fuel pump relay clicking so I think it is working. I might see if I can pick one up cheap. If so, I will do that just to make sure.
 

·
Registered
Joined
·
18,393 Posts
That is normal. When you turn the key through on it fires the lift pump for a second or two, you won't notice. then when the key hits start it no longer fires the lift pump until it starts and you let off on the key back to on. so if you are getting the 25 second run by bumping the starter and you get fuel pressure 10lb+, 12-15 is normal when running, all is normal and good.
 

·
Registered
Joined
·
110 Posts
Discussion Starter #6
I was unaware that the pump stopped while it was cranking. My buddy must not have let the key stay on run before he cranked it. I will try again and see what is up.
 

·
Registered
Joined
·
18,393 Posts
Does it start first crank every time? Does it have 10lbs while running all the time? If so just drive it and forget about it, non issue.
 
1 - 7 of 7 Posts
Top