Dodge Cummins Diesel Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hopefully I'm in the right place... So last week I noticed that I was loosing fuel pressure while driving home from work. By the time i got back my fuel pressure would never go above 10 psi and would drop to zero with any throttle. Its had a Walbro GSL-392 lift pump on for 50k miles and i assumed that it had crapped out. I replaced it with the same/new pump yesterday. While driving home from work today it did the same thing, never getting above 10 psi and dropping to zero with hany throttle.

Any thoughts or suggestions about what to try next would be much appreciated.

Brad
 

·
Registered
Joined
·
2,860 Posts
You dont have a signature. Do you have a Ppumped conversion truck? a standard VP44 pump needs 28psi idle and nothing under 10 WOT.

the Ppump is another story..Nothing under 55PSI WOT (that is what I got told by a guy who has a diesel shop and makes sled pullers as well as big tractor pulls

Your best bet is the 98.5-02 Powertrain forums.

Also what fuel pressure gauge kit u have?
 

·
Registered
Joined
·
439 Posts
There should be a course filter/strainer before the pump, check to see if that's clogged. Also check to see if there are any leaks before OR after the pump.
 

·
Registered
Joined
·
2 Posts
fule problums

fule

Hi I have a 2000 ram2500 24v and I'm not geting fule theirs a leak on top of the tank I thank my lift pump is not sinding fule my reader sed fule valve was stuck has aney one had this happen to their truck ?
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top