Dodge Cummins Diesel Forum banner
41 - 48 of 48 Posts

· Registered
Joined
·
19 Posts
Discussion Starter · #41 ·
I originally had a Napa stat in, have it sitting here it just says motorad 180F. I read about a lot of people having issues with aftermarket t stats so I called cummins, gave them the engine serial and they gave me the part number below which I ordered from Geno’s. The cummins t stat has a piece on the back that fits into the block (bypass?), the Napa did not have that though there was zero change in cooling. Also the cummins one has 2 jiggle pins that I placed at 12 & 6.

5292738
 

· Super Moderator
Joined
·
24,823 Posts
The jiggle pins is to help with the temp swings because of the big Dodges radiators.
 

· Premium Member
Joined
·
3,560 Posts
I originally had a Napa stat in, have it sitting here it just says motorad 180F. I read about a lot of people having issues with aftermarket t stats so I called cummins, gave them the engine serial and they gave me the part number below which I ordered from Geno’s. The cummins t stat has a piece on the back that fits into the block (bypass?), the Napa did not have that though there was zero change in cooling. Also the cummins one has 2 jiggle pins that I placed at 12 & 6.

5292738
That should be the correct thermostat, the disc on the back closes off the coolant bypass once the thermostat has opened up if installed correctly, the 2nd gen stat is shorter and won't fully close off the bypass allowing hot coolant to recirculate back through the block, at idle this would cause a loss of some coolant flow to the radiator
A 2nd gen stat in a 1st gen the disc would hit the block before the stat could fully open, not good.
 

· Registered
Joined
·
19 Posts
Discussion Starter · #44 ·
So just to update everyone, my plan for now is to pull the injectors and have them tested (hopefully sometime this week or next) and then if those check out, buy a pump timing adapter to verify timing. I also have the old injectors that I pulled off the engine before rebuilding, I saw the engine run with those injectors but they are pretty damn dirty looking. I was contemplating cleaning them up and throwing them in just to see if there was any change.

Destroked 450- Is there anyway you could confirm whether you have any air being blown back forward through the radiator towards the bottom corners? I know it sounds weird, but feeling my 7.3 uniformly sucking air through the rad with a constant 30 degree delta t and the cummins truck sucking and blowing air all around with a constant 10 degree delta I feel that is part of my problem along with the high EGT’s being the major contributor.
 

· Registered
Joined
·
66 Posts
So just to update everyone, my plan for now is to pull the injectors and have them tested (hopefully sometime this week or next) and then if those check out, buy a pump timing adapter to verify timing. I also have the old injectors that I pulled off the engine before rebuilding, I saw the engine run with those injectors but they are pretty damn dirty looking. I was contemplating cleaning them up and throwing them in just to see if there was any change.

Destroked 450- Is there anyway you could confirm whether you have any air being blown back forward through the radiator towards the bottom corners? I know it sounds weird, but feeling my 7.3 uniformly sucking air through the rad with a constant 30 degree delta t and the cummins truck sucking and blowing air all around with a constant 10 degree delta I feel that is part of my problem along with the high EGT’s being the major contributor.
I find a fan flows best if the fan blades are placed half in the shroud. Viewing from the side you will see rear half of fan. Front will be in shroud. Too far in shroud the air exiting fan to rear will strike shroud creating turnbulence.I have made a couple shrouds out of fiberglass for swaps. Have 93 using 93 radiator with all front accessories from 94(including fan, fan clutch and mounting. Puts fan off center to one side so had to fabricate a shroud to fit it. Only gets to 180 on hot day with a load.
 

· Read Only
Joined
·
3,593 Posts
Antonm, It looks like you are still in the process of your swap and your other trucks are sticks? I was curious if you had any input on EGTs at idle in drive as they seem really high to me 550-660? from what I can find on the forums it seems like 450 or so should be normal.
Looks like 450 is about right for EGT at idle while in drive (at least on a P-pump engine, I assume the VE would be similar). The below pic was taken after about a 45 minute drive with the ambient temp in the low 80's (early morning temps here in TX). Truck was idling in drive with the AC on.

Font Gauge Auto part Technology Display device
 

· Registered
Joined
·
19 Posts
Discussion Starter · #47 ·
Awesome thanks! Sounds like I am running about 100-150 degrees hotter EGTs at idle in neutral and drive compared to most 12 valves.
 

· Registered
Joined
·
19 Posts
Discussion Starter · #48 ·
So after breaking my stock trimmed 7.3 fan shroud while removing it I ended up driving the truck for a couple weeks with no shroud. There was no difference in cooling compared to the 7.3 shroud. I took some measurements of where my 7.3 f250 fan sits (1/2 in/out) of the shroud and decided to make a fiberglass shroud for the cummins. It needed to be about 2.5 inches deep vs the 5 inch deep 7.3 shroud. I could stick a piece of paper on the front of the radiator with the 7.3 shroud on or even without the shroud and I would get air being sucked through in the middle of the radiator, but blown back toward the front of the truck at the bottom and sides of the radiator. With the fiberglass fan shroud allowing the Cummins fan to sit about 1/3-1/2 way out of the shroud I am getting suction (paper stuck to rad) through the radiator everywhere. In traffic/normal driving conditions it stays right at 180 now. I have seen it get up to 190 after purposely leaving it in drive for 3-5 min parked where before it would have been up to 200+ in that amount of time. It definitely runs cool enough to where I could let my girlfriend drive it to work now and not worry about it running hot. We are going to take it on its first trip at the end of the month, a 500 mile round trip to padre island national seashore so I feel much better now that I don’t have to worry about the temp creeping. I still think the EGT’s are about 100 degrees too high at idle I neutral and drive but that is something I think I will have to try to track down after we get back. Truck runs great otherwise. Couple pics of the truck and shroud mock up. Thanks for everyone’s help!


Tire Wheel Automotive tire Tread Asphalt

Tire Wheel Sky Plant Building

Automotive parking light Automotive side marker light Wheel Vehicle Tire

Automotive tire Hood Motor vehicle Automotive exterior Automotive design

Shoe Wheel Tire Automotive tire Tread
 
41 - 48 of 48 Posts
Top