Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Cummins of the Month Challenge!
1 - 20 of 51 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
So I have an 89 cummins and I bought it knowing it needed some love. Had a slight knock, not very hard, but noticeable. Also had a white has and when you gave it some, it blew white smoke. So I changed the injectors to ducky fuel injection 5x.012. Well the knock did not go away and neither did the white smoke. I noticed cylinder 6 is funky. There is white stuff built up around the 6 injector and around the manifold bolt. im thinking its the white smoke leaking from non sealed parts, especially with the 6 injector leaking still even though its brand new. Leaked at 45 ft/lbs and I tightened it to 55 ft/lbs. Its got a slight leak still and I cleaned the mating surfaces and everything. I can't figure out why there is still a knock and white smoke with brand new injectors. Where else do I look? It starts up IMMEDIATELY. It runs well but I don't want to keep driving it knocking. Timing issue? will the "1/8th inch bump" work? Need help please
 

·
SuperModerator
Joined
·
10,410 Posts
924563


Moved this to the right section for you.
 

·
Registered
95 6bt 4x4 air dog 2 Df-165 5x11 injectors air intake elbow 4”exhaust no cat 4” intake kit
Joined
·
99 Posts
So I have an 89 cummins and I bought it knowing it needed some love. Had a slight knock, not very hard, but noticeable. Also had a white has and when you gave it some, it blew white smoke. So I changed the injectors to ducky fuel injection 5x.012. Well the knock did not go away and neither did the white smoke. I noticed cylinder 6 is funky. There is white stuff built up around the 6 injector and around the manifold bolt. im thinking its the white smoke leaking from non sealed parts, especially with the 6 injector leaking still even though its brand new. Leaked at 45 ft/lbs and I tightened it to 55 ft/lbs. Its got a slight leak still and I cleaned the mating surfaces and everything. I can't figure out why there is still a knock and white smoke with brand new injectors. Where else do I look? It starts up IMMEDIATELY. It runs well but I don't want to keep driving it knocking. Timing issue? will the "1/8th inch bump" work? Need help please
Maybe valve lash adjustment I would try that first
 

·
Registered
95 6bt 4x4 air dog 2 Df-165 5x11 injectors air intake elbow 4”exhaust no cat 4” intake kit
Joined
·
99 Posts
Mine did the same thing so I did what you did with new injectors and new fuel system and found out it was my lash adjustments
 

·
Super Moderator
Joined
·
22,490 Posts
The non intercooled cylinder heads are known to crack around the injector bores. The white stuff around no 6 bore could be from a crack in the bore if the injector hold down nut is tight. Also the white stuff could be coolant.

Also more info is needed to know what you've done to the engine. Any pump mods?

Advancing the timing is what alot of people do when adding more fuel. Do you have power to the KSB so that it's hot when running?
 

·
Registered
95 6bt 4x4 air dog 2 Df-165 5x11 injectors air intake elbow 4”exhaust no cat 4” intake kit
Joined
·
99 Posts
The non intercooled cylinder heads are known to crack around the injector bores. The white stuff around no 6 bore could be from a crack in the bore if the injector hold down nut is tight. Also the white stuff could be coolant.

Also more info is needed to know what you've done to the engine. Any pump mods?

Advancing the timing is what alot of people do when adding more fuel. Do you have power to the KSB so that it's hot when running?
I will try the lash adjustment this week. Thanks!
you could adjust your timing while you’re doing your valves too cause you have to find tdc on both
 

·
Super Moderator
Joined
·
22,490 Posts
you could adjust your timing while you’re doing your valves too cause you have to find tdc on both
The VE pump has slotted holes so you just loosen the 3 IP nuts and the fuel lines at the distribution head. 1 10mm bolt then push the AFC twords the cyl head.
 

·
Registered
95 6bt 4x4 air dog 2 Df-165 5x11 injectors air intake elbow 4”exhaust no cat 4” intake kit
Joined
·
99 Posts
The VE pump has slotted holes so you just loosen the 3 IP nuts and the fuel lines at the distribution head. 1 10mm bolt then push the AFC twords the cyl head.
That’s right I’m sorry man I forgot pre 94 trucks had the ve pump (which I don’t know anything about)
 

·
Super Moderator
Joined
·
22,490 Posts

·
Registered
95 6bt 4x4 air dog 2 Df-165 5x11 injectors air intake elbow 4”exhaust no cat 4” intake kit
Joined
·
99 Posts
But mine was a 88 the first year and maybe only year they put Quadra jet injection on the 350
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #15 ·
The non intercooled cylinder heads are known to crack around the injector bores. The white stuff around no 6 bore could be from a crack in the bore if the injector hold down nut is tight. Also the white stuff could be coolant.

Also more info is needed to know what you've done to the engine. Any pump mods?

Advancing the timing is what alot of people do when adding more fuel. Do you have power to the KSB so that it's hot when running?
Just bought the truck. The power screw was slightly turned up and the smoke screw was turned in a little also. The injector hold down nut was pretty tight. All the others turned out pretty easy. That one was tight all the way out. Engine has an intercooler and turbo out of a second gen. that's all the mods I was told
 

·
Registered
95 6bt 4x4 air dog 2 Df-165 5x11 injectors air intake elbow 4”exhaust no cat 4” intake kit
Joined
·
99 Posts
Do you not have a pyrometer or boost gauge or anything of that sort on the truck?
 

·
Registered
95 6bt 4x4 air dog 2 Df-165 5x11 injectors air intake elbow 4”exhaust no cat 4” intake kit
Joined
·
99 Posts
Well when you did drive it what was your pyro running?
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #20 ·
Mine did the same thing so I did what you did with new injectors and new fuel system and found out it was my lash adjustments
Hey I just adjusted my valve lash and that didn’t seem to do anything. It seems like it’s missing a cylinder? It shakes a ton at idle and It’s hard to start when it’s been sitting for a few hours. It sat all winter. Could the fuel be bad? I do have some blow by. Is it a dead cylinder?
 
1 - 20 of 51 Posts
Top