Dodge Cummins Diesel Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Hello All

Well I have a 2007 2500 6.7 6speed auto that burned up the trans pump and 5th and 6th gear clutches at 10k miles! The truck is stock and I pull an 8800 lbs trailer. Has any one else had any problems with their auto trans? Oddly enough mine was the second one to be dropped off for the same problem at this dealership the same day! Sound like the 6 speed auto may not be as great as we hoped!
:CRY:
 

·
Premium Member
Joined
·
1,958 Posts
sorry to hear that bud but at least you have a warranty. i dont have an auto so no experience. good luck
 

·
Washington Chapter Vice President
Joined
·
5,055 Posts
Bummer dude. Sounds like you may have gotten a weak Tranny. Many are getting a lot more out of theirs.
 

·
Registered
Joined
·
5,957 Posts
Probably just a coincidence that two trucks had that same problem at the same dealership. I have not read of many problems with the 68re. There are always going to be some with problems though. There's no way around that....
 

·
Premium Member
Joined
·
819 Posts
That was the first problem I had with my first tranny and now tranny # two is on its way out. I don't see how guys are seeing 500+ HP on the stock tranny. I haven't raced,did any boost launches or abused it. I am waiting for a race tranny, I don't think i'm near 500HP or maybe I'm just having bad luck.
 

·
Registered
Joined
·
1,929 Posts
sorry to hear that bud but at least you have a warranty. i dont have an auto so no experience. good luck
+1, that's partly why I went with the manual.
 

·
Registered
Joined
·
2,882 Posts
That was the first problem I had with my first tranny and now tranny # two is on its way out. I don't see how guys are seeing 500+ HP on the stock tranny. I haven't raced,did any boost launches or abused it. I am waiting for a race tranny, I don't think i'm near 500HP or maybe I'm just having bad luck.
That sucks having to do the trany twice already. I am not sure why some of them are holding up under pressure and some are not. I spoke with Jon Niemeyer the other day and his trany is working perfect...even with his extensive engine modifications. I recall that you are going to add some more performance parts to the trany...hopefully it will help keep it together this time. Good luck!
 

·
Premium Member
Joined
·
819 Posts
That sucks having to do the trany twice already. I am not sure why some of them are holding up under pressure and some are not. I spoke with Jon Niemeyer the other day and his trany is working perfect...even with his extensive engine modifications. I recall that you are going to add some more performance parts to the trany...hopefully it will help keep it together this time. Good luck!
I just called sun coast they have a tranny that they are testing now. The guy said they are installing 90HP injectors today and throwing slicks on the truck and heading to the track next weekend to so how it holds up or what breaks. He said the tranny is good for 420hp but are hoping it will survive the track next weekend. I hope it survives to cause i need one.
 

·
Registered
Joined
·
2,578 Posts
Just a week or two ago someone posted on here about being stranded out in Pismo with a blown tranny... supposedly another truck was at the same dealership with a blown trans as well.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #11
Thank you all for your replies.

I spoke with the tech working on my Trans, he said these where the first two 68re’s he’s had to go into. He thinks the pump went out and then took out the 5th and 6th clutches. I had complained about the shifting of this Trans at 1500 miles, the local dealer said it was fine yet they re-flashed the Trans computer. Since this is the first diesel I have owned I reluctantly said ok. My Trans had more of a flare shift in 4th, 5th and 6th gear on up shift and down shift than 1st, 2nd and 3rd. since haven’t drove any others do any of you notice this in your trans? Thank you for any input.
 

·
Registered
Joined
·
750 Posts
Thank you all for your replies.

I spoke with the tech working on my Trans, he said these where the first two 68re’s he’s had to go into. He thinks the pump went out and then took out the 5th and 6th clutches. I had complained about the shifting of this Trans at 1500 miles, the local dealer said it was fine yet they re-flashed the Trans computer. Since this is the first diesel I have owned I reluctantly said ok. My Trans had more of a flare shift in 4th, 5th and 6th gear on up shift and down shift than 1st, 2nd and 3rd. since haven’t drove any others do any of you notice this in your trans? Thank you for any input.
What exactly does your transmission do on upshifts and downshifts on these gears?
 

·
Registered
Joined
·
195 Posts
track bars for pulling

Bummer dude. Sounds like you may have gotten a weak Tranny. Many are getting a lot more out of theirs.
hey compcowboy or any one else i have a 3500 dulley 6 speed that weel hops bad when i take off with or with out a trailer i wanted to put track. bars on it but i was not shure if that would be safe hauling hevy loads ???? any one know about that??????
 

·
Registered
Joined
·
1,554 Posts
Hello All

Well I have a 2007 2500 6.7 6speed auto that burned up the trans pump and 5th and 6th gear clutches at 10k miles! The truck is stock and I pull an 8800 lbs trailer. Has any one else had any problems with their auto trans? Oddly enough mine was the second one to be dropped off for the same problem at this dealership the same day! Sound like the 6 speed auto may not be as great as we hoped!
:CRY:


145K miles on the 6.7L Auto without any problems. It is pulling 20k pounds on a daily basis. Sounds like you just got a bad apple in the bunch :thumbsup
 

·
Registered
Joined
·
1,554 Posts
hey compcowboy or any one else i have a 3500 dulley 6 speed that weel hops bad when i take off with or with out a trailer i wanted to put track. bars on it but i was not shure if that would be safe hauling hevy loads ???? any one know about that??????

I have track bars on my 07 5.9 3500. It has a 6" lift with 37x13.5x18 Toyo's. They are made by warrior products. I have replaced one of the brackets 2 times from them. I have cracked the welds. The track bars help the wheel hop but they don't allow the rear end to move freely which puts a lot of stress on the bars. I only did the bars because I haul my 40' toy hauler through the sand dunes. I wouldn't waste the money again though as it has just been a big headache from day 1
 

·
Registered
Joined
·
2,308 Posts
145K miles on the 6.7L Auto without any problems. It is pulling 20k pounds on a daily basis. Sounds like you just got a bad apple in the bunch :thumbsup
Yep!!!! same here. I do my 35k maintaince all the time with minimal shavings on magnet!!!
 

·
Registered
Joined
·
844 Posts
with the stack in my sig all on high(~450hp) I did a boosted 4x4 lauch and welded clutch 1 to the housing. I am going sled pulling for the 1st time this weekend so we will see how she holds up(tranny #2). I talked to ATS and suncoast and they won't have a programmer out for the 68RE until Jan. or Feb. CRAP! Firmer shifts and higher line pressure would help us all.
 
1 - 17 of 17 Posts
Top