Dodge Cummins Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2006 2500 4x4 5.9,,Just changed my OEM waterpump at 238k,replaced radiator,all hoses,thermostat and closed vein waterpump,now the temp runs a little hotter than what it was running,at 75mph it would run 185-195,now it runs 200 and up at 65,the OEM waterpump was an open metal vein pump,thinking of changing it back and putting a 180 thermostat in it,,,has anyone had this problem

New to the group,, thanks for any advise,tried searching and came up with lots of build threads
 

·
On call 24/7
Joined
·
12,412 Posts
Did you put in a 200 thermostat or a 190? I’ve used both types of water pumps and never made a difference on temps
 

·
Trying to learn
Joined
·
5,841 Posts
Nothing wrong with running at 200º.
I do use a 200º thermostat and it runs at 202-204º which is good.
Many miles by members here show that improved mpg can be had by running that little bit extra heat.
Don't do a 180º thermostat. Do an OEM 190º or a 200º.
 
  • Like
Reactions: rghavana

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Not sure what temp stat they gave me,i'll have to check the part number,just dont like it running that warm and not even pulling a trailer,and didnt want to have it running hotter with a trailer,its just never ran this warm and just figured it was the closed vein pump,thanks I'll, check in to which thermostat they gave me
 

·
Registered
Joined
·
4,955 Posts
You're not driving a gasser, it's a diesel, and they run better hot, and 200 is not hot!
 
1 - 6 of 6 Posts
Top