Dodge Cummins Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter #1
got some tranny problems looking for some tips to try and fix it myself. around 30mph it seems like it would get out of lock-up then it would be fine after 40mph or so. now in drive it seems like the parking brake is on, very sluggish. i drained and changed the filter along with adjusting the bands but its still the same way. any help would be appreciated.

01 2500 with 84,000 miles
stock truck, 4" exhaust
 

·
Registered
Joined
·
1,258 Posts
Any codes? What did the drained fluid look like?

Ops
 

·
Registered
Joined
·
180 Posts
Discussion Starter #3
No codes, the tranny fluid was dark brown stunk like used 90w

01 2500 with 84,000 miles
stock truck, 4" exhaust
 

·
Registered
Joined
·
4,118 Posts
sounds like you've burnt some clutches.
 

·
Registered
Joined
·
180 Posts
Discussion Starter #5
I just tried the key code trick and pulled 3 codes, p-1762 p-1693- ECU p-0230 could this be electric problems?

01 2500 with 84,000 miles
stock truck, 4" exhaust
 

·
Registered
Joined
·
1,258 Posts
Brown fluid means you have burned a clutch pack. Time for either an overhaul or a new trans.

Ops
 

·
Tech Specialist
Joined
·
459 Posts
first check for excess material in the pan. if none found, then do as follows. p1762 is a governor pressure code. suggest changing pressure transducer and governor pressure solenoid. the fluid has overheated the sensors and now they read the wrong pressure. the vehicle is starting in second gear. be sure to flush to fluid when you are done.
 
1 - 7 of 7 Posts
Top