Dodge Cummins Diesel Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
527 Posts
Discussion Starter #1
Ok, well here is the deal. When I first got my Holley Black pump it said 6PSI, stretched the spring and was able to get 10psi idle and 8 at WOT. I just said screw it, the guage is probably off. Well just today I loaded the Comp3 tune(its great by the way) and now it says 37-45PSI(it bounces around a little). So what is the deal??? Am I really getting that much???
Thanks,
Chris
 

·
Rescue Tower
Joined
·
10,827 Posts
There is no way we can tell over the internet... You need to verify with a second gauge...
 

·
Registered
Joined
·
155 Posts
I dont think you can get that much from a black. maybe 21 tops, but i have heard of weirds things before
 

·
Registered
Joined
·
527 Posts
Discussion Starter #5
No, I was not running the new transducer(although I am not sure what that is). I am thinking of putting the valve stem back in the bleeder valve and seeing what a tire guage reads. Afterall, pounds per square inch are pounds per square inch, right?
 

·
Tech Specialist
Joined
·
1,496 Posts
It's impossible for a black to push that pressure even if the bypass is completely blocked off.
 

·
Premium Member
Joined
·
1,381 Posts
No, I was not running the new transducer(although I am not sure what that is).
I am assuming you are running the old, big sending unit, that has 1 wire connected to it?

If that is the case, the new software does not work with that sending unit, only the transducer.

If that is the case I need to make you a different software update. According to our records we have recieved all the old sending units?? That is why the new update does not support it.
 

·
Registered
Joined
·
35 Posts
According to our records we have recieved all the old sending units?? That is why the new update does not support it.
Well you got one more coming yet. :thumbsup:

It should be there soon hopefully by the end of the week for the upgrade.
 

·
Registered
Joined
·
1,331 Posts

·
Registered
Joined
·
527 Posts
Discussion Starter #10
I am running a 0-100psi fuel pressure sending unit, I will have to look and see what brand it is, but there are two wires coming from it. I believe it was $50...

I bought the unit separate from Quadzilla yet used the original harness to hook it up.
 

·
Western WA President
Joined
·
8,439 Posts
mechanical fuel pressure gauge is the way to go...I don't trust electronic gauges. small amount of electrical noise or moisture on the wires can throw the readings off.
 

·
Registered
Joined
·
527 Posts
Discussion Starter #12
I agree with that...I am probaby going to get mechanical FP as well as boost and drive pressure guages..
 
1 - 12 of 12 Posts
Top