Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Back Story:
Before this truck decide it wasn’t going to start, it lost power and would only travel around 40mph.

Currently, it will crank, but not start. Can hear a clicking noise from the back of the fuel pump. I have check the #6 and #9 fuses. Both are good. Has a new battery and battery cables. Attempted to use a code reader. It had a non communication error. That could be user error.

What do I try next?
 

·
Registered
Joined
·
2,496 Posts
You mean clicking behind the injection pump?

If you bump the starter does the lift pump in the tank run?
 

·
Trying to learn
Joined
·
7,909 Posts

·
Premium Member
Joined
·
102 Posts
I read somewhere on here, that fuel x-over tubes not being tight had caused this. I re torqued mine today, and the truck starts on its own now.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 · (Edited by Moderator)
View attachment 924024

Truck information always helps, year, mileage, and any mods/add-ons it has.

Should have 2 batteries.
Both were changed.
Truck has 364,000 miles. No mods.

You mean clicking behind the injection pump?

If you bump the starter does the lift pump in the tank run?
Clicking is behind the injection pump. How do I know if the lift pump is working?
 

·
Premium Member
Joined
·
102 Posts
I got a bluedriver scan tool to, can read and reset you codes, and monitor rail pressure and such in real time
 
1 - 8 of 8 Posts
Top