Dodge Cummins Diesel Forum banner
1 - 20 of 108 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 · (Edited)
I have a new to me 2019 2500 6.7 with 12k miles, all stock, RFE68, non-ho, 295x65x20 and I’m pulling an 8.5k lb boat. I can hardly get to 65mph on an 8% grade on a 90degree day pedal to the floor, max boost 27psi and MAF reading 40. My son has an F-150 eco boost that will easy pull the same boat up the same hill at 70 with power to spare. Seems way wrong to me as I’m suppose to have nearly double the torque. Any ideas on what the problem can be ?
 

Attachments

·
Registered
Joined
·
49 Posts
Discussion Starter · #10 ·
What else will your obd reading pull? Fuel pressure. Throttle position.

Any codes?
I was looking at a number of things.. has a lot of options to read but dashboards on it suck so I have not made it super far.

Only other thing I saw as Air Temp on the exit side of the Intercooler were 140F.
No Codes on the reader other than a stick mirror sensor which of course is trivial.
 

·
Registered
Joined
·
717 Posts
i would look at trying to get a pretty solid data log of a variety of driving conditions, just so u can possibly see any readings that are out of wack from the normal, odd there’s no CELs
 

·
Red Rider
2022 RAM 5500 Tradesman Crew Cab & Chassis 4X4
Joined
·
16,503 Posts
2500 with RFE69 non-ho
If it’s a 2500....it’s a given that it’s an SO (not non-Ho) engine.

In any event...you have not mentioned any of the following:
  • Idle hours on truck
  • drive hours on truck
  • miles on truck
  • maintenance history of truck
I’d seriously look into the simple stuff first....like fuel filters (how old are they...are they possibly some junk IFJF, Korop, or Diesly schittttt from China) and I’d look into the air filter as well.

Junk air filters can collapse partially and cause problems.
 

·
Registered
Joined
·
5,156 Posts
It never goes above 27psi? 27 isn’t bad but it should peak a bit higher.
 

·
Registered
2015 Ram 2500, Longhorn Laramie LTD, 6.7L CTD
Joined
·
452 Posts
I have a new to me 2019 2500 6.7 with 12k miles, all stock, RFE68, non-ho, 295x65x20 and I’m pulling an 8.5k lb boat. I can hardly get to 65mph on an 8% grade on a 90degree day pedal to the floor, max boost 27psi and MAF reading 40. My son has an F-150 eco boost that will easy pull the same boat up the same hill at 70 with power to spare. Seems way wrong to me as I’m suppose to have nearly double the torque. Any ideas on what the problem can be ?
what gear were you in?
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #18 ·
If it’s a 2500....it’s a given that it’s an SO (not non-Ho) engine.

In any event...you have not mentioned any of the following:
  • Idle hours on truck
  • drive hours on truck
  • miles on truck
  • maintenance history of truck
I’d seriously look into the simple stuff first....like fuel filters (how old are they...are they possibly some junk IFJF, Korop, or Diesly schittttt from China) and I’d look into the air filter as well.

Junk air filters can collapse partially and cause problems.
Not sure in idle hours or Drive but I'll get it an update.
Miles on truck = 12,000
Not much info on mx history as I'm second owner and now details from previous
 

·
Registered
Joined
·
210 Posts
Taking it to the dealer you bought it from? Are they a Ram dealer? It shouldn't be performing like. I hope they get her fixed up the right way because she won't disappoint when performing as designed.
 
1 - 20 of 108 Posts
Top