Dodge Cummins Diesel Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
Hey fellas hope you can help me out
I have a 2007 5.9L that I have owned for about a month now. I seem to be one of the lucky ones with the 70 mph vibration, and also the truck seems to gear hunt @ light throttle. Does my build year already have the new tranny servo to help the gear hunting, and what are the odds of getting the dealership to help with the vibration ?? Only 18,000 miles on her.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #3
Just made an appointment for tomorrow morning with the dealership..I will keep you all posted on the fixes. Hopefully it goes smooth... this is the first Dodge I ever owned, I gotta say it's has me a little worried so far........ but pulls like a mutha !!!! :woot:
 

·
Banned
Joined
·
4,630 Posts
Supposedly Dodge made some mild changes to the 48RE's in '06.5...but am not sure, so you'll have to see what they say....
 

·
Registered
Joined
·
54 Posts
Discussion Starter #6
Anybody else having problems with the 70mph vibration in the 06-07 models ? It's not violent.. just a constant vibe that I hear and feel in through the go fast pedal and steering wheel. Thanks for all the feed-back
 

·
Registered
Joined
·
1,257 Posts
Anybody else having problems with the 70mph vibration in the 06-07 models ? It's not violent.. just a constant vibe that I hear and feel in through the go fast pedal and steering wheel. Thanks for all the feed-back
I don't have the vibration prob but I do have the gear hunting prob. Sounds like the 2 are unrelated. Plus, the gear huntin is only at light throttle. :confused:
 

·
Registered
Joined
·
149 Posts
I'm having the hunting issues also, no vibration though. Took truck to dealer last weekend and they couldn't find anything wrong showed them the TSB#21-009-07. For some reason it didn't come up when they ran my vin. Either way the dealer agreed to do it I just need to reschedule. Don't let them talk you out of them doing it under warrenty.:beer
 

·
hydraulic lifter crew
Joined
·
12,561 Posts
i know there was a drive shaft issue on the long beds i believe for my year model, sounds like a similar issue maybe ? they replaced it under warranty at 35k miles.
it was an out of balance drive shaft.
 

·
Registered
Joined
·
10 Posts
I had a vibration and the dealer changed my driveshaft - did not fix the problem.

I took it to a tire store and had them check the tires. Two of the wonderful General tires were out of round. The truck had 8400 miles on it when this occured.

I took it to a General tire dealer and they replaced the two tires.

Problem solved for a while - it is doing it again (10,500 miles) just not as bad, I suspect another tire.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #11
I had a vibration and the dealer changed my driveshaft - did not fix the problem.

I took it to a tire store and had them check the tires. Two of the wonderful General tires were out of round. The truck had 8400 miles on it when this occured.

I took it to a General tire dealer and they replaced the two tires.

Problem solved for a while - it is doing it again (10,500 miles) just not as bad, I suspect another tire.

I took the truck in and had the tires rotated and balanced to see if that would help, but nothing. I don't have the stock tires on, but it did it before the tire change anyway..... I dropped the truck off at the dealership this am...hope they can fixer up
 

·
Premium Member
Joined
·
3,791 Posts
Anybody else having problems with the 70mph vibration in the 06-07 models ? It's not violent.. just a constant vibe that I hear and feel in through the go fast pedal and steering wheel. Thanks for all the feed-back

I used to have the vibration problem, then it mysteriously went away. I got nuthin for ya'.:thud:
 

·
Registered
Joined
·
54 Posts
Discussion Starter #14
DieselRookie.. Nope not yet, but they did call me yesterday to let me know that they lost my key :CRY: The service rep. started off by saying they needed more time to trouble shoot, but then came clean and told me they "misplaced" my key...
 

·
Registered
Joined
·
1,257 Posts
DieselRookie.. Nope not yet, but they did call me yesterday to let me know that they lost my key :CRY: The service rep. started off by saying they needed more time to trouble shoot, but then came clean and told me they "misplaced" my key...
That's shady dude, I think next time I'd go elsewhere!!!
 

·
Registered
Joined
·
54 Posts
Discussion Starter #16
That's shady dude, I think next time I'd go elsewhere!!!
Hey if they do the job right... then all will be good with me .. it's just kill'n me to have it in the shop... and losing key's is only making it longer ... I'm freak'n :hyper:
 

·
Registered
Joined
·
54 Posts
Discussion Starter #17
Dealership just call.... they said it is my tires. I have 33's on stock rims... would this really cause the vibe & shift problem ? They said for $135 they can recalibrate the computer to the new tire size..... does this sound right ? ??
 

·
Registered
Joined
·
1,257 Posts
Dealership just call.... they said it is my tires. I have 33's on stock rims... would this really cause the vibe & shift problem ? They said for $135 they can recalibrate the computer to the new tire size..... does this sound right ? ??
:BS:

The stock tire size is 265/70/17.
That translates to 31.61" by 10.94"...IMO this is not the problem!!! They are trying to pull a fast one on you. I have 285/70/17 (32.76" by 11.50")on mine and no Vibs.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #19
I don't think a flash will fix these problems, they say "yes".... and after talking to the supervisor awhile they agreed to do the flash for free !!!! :thud: I pick it up tonight ...Won't take long of a drive to see if things are fixed... Is there anything I need to know about the latest flash..... ya know.. in case I ever want to add some power later. :peelout
 

·
Premium Member
Joined
·
3,791 Posts
Dealership just call.... they said it is my tires. I have 33's on stock rims... would this really cause the vibe & shift problem ? They said for $135 they can recalibrate the computer to the new tire size..... does this sound right ? ??

That would be 1 1/2 HR shop rate for a 10 minute procedure. What a rip!!! I went in to my dealer for the horn honk when locking feature, and the service writer hooked up starscan and cancelled it for free. He did say that if the technicians hook up the starscan they have to charge a fee to do it, but if the service writer hooks it up--no fee.

See if the service writer can make the adjustment at a later time for free.

Heck there are companies that adjust the speedometer for about $100. That still save you $35.


EDIT: I guess I should try reading the whole thread b4 responding---oopsy!
 
1 - 20 of 25 Posts
Top